To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7620    Accepted Submission(s): 3692

Problem Description

Given a two-dimensional array of positive and negative
integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater
located within the whole array. The sum of a rectangle is the sum of all the
elements in that rectangle. In this problem the sub-rectangle with the largest
sum is referred to as the maximal sub-rectangle.

As an example, the
maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4
1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1
8

and has a sum of 15.

 

Input

The input consists of an N x N array of integers. The
input begins with a single positive integer N on a line by itself, indicating
the size of the square two-dimensional array. This is followed by N 2 integers
separated by whitespace (spaces and newlines). These are the N 2 integers of the
array, presented in row-major order. That is, all numbers in the first row, left
to right, then all numbers in the second row, left to right, etc. N may be as
large as 100. The numbers in the array will be in the range
[-127,127].
 

Output

Output the sum of the maximal sub-rectangle.
 

Sample Input

4
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1
8 0 -2
 

Sample Output

15
 
 
  这道题目是求二维数组的最大子矩阵的和,最大子矩阵一定是在1~n行之间,所以要任选连续的几行压缩成一位数组求最大连续子段和。
代码:
#include <iostream>
#include <cstdio>
using namespace std;
#define N 105
int arr[N][N],b[N];
int dp(int *a,int m) //求一维数组的最大子段和
{
int i,sum,max;
sum = 0;
max = 0;
for(i=0; i<N; i++)
{
sum += a[i];
if(sum<0)
sum = 0;
if(sum>max)
max = sum;
}
return max;
}
int main()
{
int i,j,k,n,sum,max;
while(scanf("%d",&n)!=EOF)
{
for(i=0; i<n; i++)
for(j=0; j<n; j++)
scanf("%d",&arr[i][j]);
max = 0;
for(i=0; i<n; i++)
{
memset(b,0,sizeof(b));
for(j=i; j<n; j++)
{
for(k=0; k<n; k++)
b[k] += arr[j][k];
sum = dp(b,n);
if(sum>max)
max = sum;
}
}
printf("%d\n",max);
}
return 0;
}

  

 
 

最新文章

  1. 嵌入式Linux驱动学习之路(二十七)字符设备驱动的另一种写法
  2. 网络问卷调查js实现代码
  3. ArcSoft&#39;s Office Rearrangement---hdu5933
  4. 理解Java ClassLoader机制
  5. 关于微软RDLC报表打印时文字拉伸问题(Windows server 2003 sp2)
  6. 【转】ibatis的简介与初步搭建应用
  7. android开发3:四大基本组件的介绍与生命周期
  8. (转)轻量级数据库 SQLite
  9. c/c++中宏定义##连接符 和#符的使用
  10. CentOS修改yum更新源
  11. Effective C++ 18-23
  12. object转字符串
  13. 动态在线扩容root根分区大小的方法详解
  14. 安卓ViewStub用法
  15. lua -- mysql导出json
  16. spring注入 属性注入 构造器注入 set方法注入
  17. mitmproxy实践
  18. BZOJ5142: [Usaco2017 Dec]Haybale Feast 线段树或二分答案
  19. 【TCP/IP详解 卷一:协议】第十二章 广播和多播
  20. SVM的sklearn.svm.SVC实现与类参数

热门文章

  1. 学习js 优先级
  2. js 无缝滚动效果学习
  3. $Ajax简单理解
  4. JS运算符
  5. ibatis实现Iterate的使用
  6. Oracel EBS - Search Report by Response &amp; Group
  7. Oracle ORA-01722: 无效数字 处理方法
  8. 【5集iCore3_ADP演示视频】5-5 iCore3应用开发平台示波器和信号源校准
  9. insert操作卡死的处理过程
  10. CentOS 创建SVN 服务器,并且自动同步到WEB 目录