Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing
sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of
the maximum-length common subsequence of X and Y.

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard
output the length of the maximum-length common subsequence from the beginning of a separate line.

 

Sample Input

abcfbc abfcab
programming contest
abcd mnp
 

Sample Output

4
2
0
 

题意:给两个字符串,求这两个字符串的最长公共子序列的长度。

序列特点:最长公共子序列中的字符出现的顺序和两个母串中出现的顺序是一样的。而最长公共子串则要求的更严格一点,子串中字符出现的顺序和母串中出现的顺序都必须是连续的;

代码如下:
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<ctype.h>
#include<algorithm>
#define N 1010
using namespace std; int dp[1010][1010];
int main ()
{
int n,m,i,j;
int len1,len2;
char a[N],b[N];
a[0]='-';
b[0]='-';
while(~scanf("%s %s",a+1,b+1)){//使得存的字符串从字符串的地二位开始存;
len1=strlen(a);
len2=strlen(b);
for(i=1;i<max(len1,len2);i++){//初始化
dp[i][0]=dp[0][i]=0;
}
for(i=1;i<len1;i++){
for(j=1;j<len2;j++){
if(a[i]==b[j]){
dp[i][j]=dp[i-1][j-1]+1;
}else {
dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
}
}
}
/*for(i=0;i<len1;i++){
for(j=0;j<len2;j++){
printf("%d ",dp[i][j]);
}
printf("\n");
}*/
printf("%d\n",dp[len1-1][len2-1]);
}
return 0;
}

最新文章

  1. VMware下Windows Server 2012添加新磁盘
  2. iOS中获取各种文件的目录路径的方法
  3. 如何结合自己本地数据库,使用【百度地图】API
  4. MyEclipse10优化
  5. [ASE][Daily Scrum]11.28
  6. Windows下Nginx的安装与配置(转)
  7. iOS Node Conflict svn冲突
  8. 发现一个jq的问题
  9. GridView表头排序方法设置
  10. 解决 Provider &#39;System.Data.SqlServerCe.3.5&#39; not installed. -摘自网络
  11. jQuery动态实现title的修改 失效问题
  12. 极客技术专题【007期】:jQuery初学者入门 - jQuery Event
  13. js键盘控制div移动,解决停顿问题
  14. javascript访问级别
  15. 陈一舟《情系人人》:先搞钱,再搞人才_DoNews-IT门户-移动互联网新闻-电子商务新闻-游戏新闻-风险投资新闻-IT社交网络社区
  16. 利用VGG19实现火灾分类(附tensorflow代码及训练集)
  17. iBeacon硬件厂商和产品
  18. [Python Study Notes]批量将ppt转换为pdf v1.0
  19. Nginx 调优经验记录
  20. C学习笔记-一些知识

热门文章

  1. ubuntu16.04下无线网卡无法正常连网
  2. redis.conf 配置 详解 中文 2.8
  3. 项目中同一个dll的x86和x64同时引用
  4. Codeforces 1091 Good Bye 2018
  5. 谈谈java中的final关键字
  6. 指数循环节 求A的B次方模C
  7. python调用虹软2.0第三版
  8. apache安装方式
  9. MyBatis中的@Mapper注解 @Mappe与@MapperScan关系
  10. GetImageURL