A table tennis club has N tables available to the public. The tables are numbered from 1 to N. For any pair of players, if there are some tables open when they arrive, they will be assigned to the available table with the smallest number. If all the tables are occupied, they will have to wait in a queue. It is assumed that every pair of players can play for at most 2 hours.

Your job is to count for everyone in queue their waiting time, and for each table the number of players it has served for the day.

One thing that makes this procedure a bit complicated is that the club reserves some tables for their VIP members. When a VIP table is open, the first VIP pair in the queue will have the priviledge to take it. However, if there is no VIP in the queue, the next pair of players can take it. On the other hand, if when it is the turn of a VIP pair, yet no VIP table is available, they can be assigned as any ordinary players.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (<=10000) - the total number of pairs of players. Then N lines follow, each contains 2 times and a VIP tag: HH:MM:SS - the arriving time, P - the playing time in minutes of a pair of players, and tag - which is 1 if they hold a VIP card, or 0 if not. It is guaranteed that the arriving time is between 08:00:00 and 21:00:00 while the club is open. It is assumed that no two customers arrives at the same time. Following the players’ info, there are 2 positive integers: K (<=100) - the number of tables, and M (< K) - the number of VIP tables. The last line contains M table numbers.

Output Specification:

For each test case, first print the arriving time, serving time and the waiting time for each pair of players in the format shown by the sample. Then print in a line the number of players served by each table. Notice that the output must be listed in chronological order of the serving time. The waiting time must be rounded up to an integer minute(s). If one cannot get a table before the closing time, their information must NOT be printed.

Sample Input:

9

20:52:00 10 0

08:00:00 20 0

08:02:00 30 0

20:51:00 10 0

08:10:00 5 0

08:12:00 10 1

20:50:00 10 0

08:01:30 15 1

20:53:00 10 1

3 1

2

Sample Output:

08:00:00 08:00:00 0

08:01:30 08:01:30 0

08:02:00 08:02:00 0

08:12:00 08:16:30 5

08:10:00 08:20:00 10

20:50:00 20:50:00 0

20:51:00 20:51:00 0

20:52:00 20:52:00 0

3 3 2

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <queue> using namespace std;
#define INF 21*3600
#define MAX 10000
int CurrTime[MAX+5];
int numTable[MAX+5];//桌子被玩的次数
//用户的结构体
struct Player
{
int startTime;//到达的时间
int waitTime;//等待的时间
int playTime;//玩耍的时间
}VipPlayer[MAX+5],OriPlayer[MAX+5];
int n;//n个人
int k,m;//桌子的数量,vip桌子的数量
int cmp(Player a,Player b) {return a.startTime<b.startTime;}//比较函数,快速排序
int VipNumber;//会员的人数
int OriNumber;//普通的人数
bool vipTag[MAX+5];//标记vip桌子
void printTime(int time)
{
int hh,mm,ss;
ss=time%60;
mm=time/60%60;
hh=time/3600;
printf("%02d:%02d:%02d ",hh,mm,ss);
}
int main()
{
scanf("%d",&n);
int hh,mm,ss,time,tag;
VipNumber=1;OriNumber=1;
for(int i=1;i<=n;i++)
{
scanf("%d:%d:%d",&hh,&mm,&ss);
int sum=hh*3600+mm*60+ss;
scanf("%d%d",&time,&tag);
if(time>120)//如果超过两个小时,要进行限制
time=120;
if(hh>=21) continue;//如果超出营业时间,要进行限制
if(tag)//如果是vip
{
VipPlayer[VipNumber].startTime=sum;
VipPlayer[VipNumber].waitTime=0;
VipPlayer[VipNumber++].playTime=time;
}
else//如果不是
{
OriPlayer[OriNumber].startTime=sum;
OriPlayer[OriNumber].waitTime=0;
OriPlayer[OriNumber++].playTime=time;
}
}
scanf("%d%d",&k,&m);//输入桌子数量和vip桌子数量
int xx;memset(vipTag,0,sizeof(vipTag));
memset(numTable,0,sizeof(numTable));
for(int i=1;i<=m;i++)
{
scanf("%d",&xx);
vipTag[xx]=1;
}
//对普通和vip进行排序
sort(VipPlayer+1,VipPlayer+VipNumber,cmp);
sort(OriPlayer+1,OriPlayer+OriNumber,cmp);
int i=1,j=1;
int index=-1;
for(int i=1;i<=k;i++)
CurrTime[i]=8*3600;
while(i<VipNumber||j<OriNumber)
{
int minTime=INF,VipTime=INF,OriTime=INF;
for(int p=1;p<=k;p++)
{
if(CurrTime[p]<minTime)
{
minTime=CurrTime[p];
index=p;
}
}
if(i>VipNumber&&j>OriNumber)
break;
if(i<VipNumber) {VipTime=max(VipPlayer[i].startTime,minTime);}
if(j<OriNumber) {OriTime=max(OriPlayer[j].startTime,minTime);}
bool VipServe=true;
if(VipTime>OriTime&&OriTime<21*3600) {VipServe=false;}
else if(OriTime>VipTime&&VipTime<21*3600) {VipServe=true;}
else if(OriTime==VipTime&&OriTime<21*3600)
{
if(vipTag[index]||(!vipTag[index]&&VipPlayer[i].startTime<OriPlayer[j].startTime))
VipServe=true;
else
VipServe=false;
}
else if(OriTime==21*3600&&VipTime==21*3600)
{
break;
}
//判断当前桌子可以为谁服务
if(VipServe)
{ if(!vipTag[index])
{
for(int p=1;p<=k;p++)
{
if(vipTag[p]&&CurrTime[p]==minTime)
{ index=p;
}
} }
VipPlayer[i].waitTime=VipTime;
CurrTime[index]=VipTime+VipPlayer[i].playTime*60;
numTable[index]++; printTime(VipPlayer[i].startTime);
printTime(VipPlayer[i].waitTime);
printf("%d\n",(VipPlayer[i].waitTime-VipPlayer[i].startTime+30)/60);
i++;
}
else
{
OriPlayer[j].waitTime=OriTime;
CurrTime[index]=OriTime+OriPlayer[j].playTime*60;
numTable[index]++; printTime(OriPlayer[j].startTime);
printTime(OriPlayer[j].waitTime);
printf("%d\n",(OriPlayer[j].waitTime-OriPlayer[j].startTime+30)/60);
j++;
} }
printf("%d",numTable[1]);
for(int i=2;i<=k;i++)
printf(" %d",numTable[i]);
printf("\n");
return 0; }

最新文章

  1. eclipse中 将java项目转换为web项目
  2. Python socket编程之一:
  3. Base64把图片、文件转码成字符串(互转)
  4. 关于MessageBox的用法
  5. LINUX怎么修改IP地址
  6. HDU Computer Transformation1041 题解
  7. webpack vue2.0项目脚手架生成的webpack文件
  8. Spring学习札记(一)
  9. 【js】JS实现的base64加密、md5加密及sha1加密详解
  10. Spring Boot JPA的Column Table 注解命名字段无效
  11. Java 之 Web前端(二)
  12. EasyARM-iMX283A的U盘使用教程
  13. LSOF查看linux中文件打开情况
  14. 解决Elasticsearch问题的一些心得体会
  15. YISMILE微信小程序使用说明
  16. Solr7.4.0的API(Solrj)操作
  17. mysql主从备份功能配置与測试
  18. thread safe
  19. opencart安装和使用PHPMailer
  20. CentOS 7安装zabbix步骤

热门文章

  1. uint64, sizet_t, ssizet_t
  2. linux下实现CPU使用率和内存使用率获取方法
  3. MySQL 5.7 双主复制+keepalived,常规业务一般够用了
  4. angular学习疑问总结
  5. 李洪强iOS开发之苹果企业开发者账号申请流程
  6. CentOS 6.2下更新GCC
  7. 偏于SQL语句的 sqlAlchemy 增删改查操作
  8. CSS学习笔记(9)--详解CSS中:nth-child的用法
  9. [转]SOA接口的两种常用实现比较:SOAP vs REST
  10. 回车替换Tab 并不会 提交表单 IE Chrome 通过