Kill the monster

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1241    Accepted Submission(s): 846

Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it.
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 
Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 
Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 
Sample Input
3 100
10 20
45 89
5 40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40

 
Sample Output
3
2
-1
 #include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
int mapp[11][2];
int vis[11];
int minn,n,m,flag;
void dfs(int bloor,int time)
{
 int i,j;
 if(bloor<=0)
 {
 // cout<<".."<<endl;
  if(minn>time) minn=time;
 // cout<<maxx<<endl;
  flag=1;
  return;
 }
 if(time>=minn) return ;//  当次数比以前走过的次数多的时候 剪去
 for(i=1;i<=n;i++)
 {
  if(vis[i]==1) continue;
  vis[i]=1;
 // cout<<".."<<endl;
  if(bloor<=mapp[i][1])
  {
  // cout<<".."<<endl;
      dfs(bloor-2*mapp[i][0],time+1); 
     }
  else
  {
  // cout<<".."<<endl;
   dfs(bloor-mapp[i][0],time+1);
  }
  vis[i]=0;
 }
}
int main()
{
 int i,j;
 while(cin>>n>>m)
 {
  for(i=1;i<=n;i++)
  {
   scanf("%d %d",&mapp[i][0],&mapp[i][1]);
  // cout<<mapp[i][0]<<mapp[i][1]<<endl;
  }
  memset(vis,0,sizeof(vis));
  flag=0;
  minn=999;
  dfs(m,0);
  if(flag==0) printf("-1\n");
  else printf("%d\n",minn);
 }
 return 0;
}

最新文章

  1. Android点击列表后弹出输入框,所点击项自动滚动到输入框上方
  2. Android Studio 如何切换sdk
  3. 把表里的数据转换为insert 语句
  4. iOS 瀑布流的基本原理
  5. Redis persistence demystified - part 2
  6. 【英语】Bingo口语笔记(33) - 面部器官系列
  7. 转:视频压缩的基本概念(x264解压包)
  8. PHP 调用外部程序的几种方式
  9. fgets和scanf的区别
  10. Oracle误删表空间文件后数据库无法启动
  11. 【转】OpenCV与CxImage转换(IplImage)、IplImage QImage Mat 格式互转
  12. 转:JDBC驱动配置相关
  13. java课设-计算数学表达式的程序,201521123050,51 团队
  14. redis安装linux(二)
  15. linux 网络命令
  16. 【转】Linux 移动或重命名文件/目录-mv 的10个实用例子
  17. socket 聊天室
  18. Python内置数据结构--列表
  19. 20155308《网络对抗》Exp4 恶意代码分析
  20. Linux中常用的函数

热门文章

  1. Learning Conditioned Graph Structures for Interpretable Visual Question Answering
  2. python-pptx
  3. input标签在谷歌浏览器记住密码的自动填充问题
  4. Android Support v4、v7、v13、v14、v17的区别和应用场景
  5. Flutter 中SimpleDialog简单弹窗使用
  6. mobile crane 1
  7. netty5自定义私有协议实例
  8. hadoop记录-flink测试
  9. Django之Restful API
  10. Python - Django - ORM 自定义 char 类型字段