A. Tutor

Description

Lilin was a student of Tonghua Normal University. She is studying at University of 

Chicago now. Besides studying, she worked as a tutor teaching Chinese to Americans. So, 

she can earn some money per month. At the end of the year, Lilin wants to know his 

average monthly money to decide whether continue or not. But she is not good at 

calculation, so she ask for your help. Please write a program to help Lilin to calculate the 

average money her earned per month.

Input

The first line contain one integer T, means the total number of cases.

Every case will be twelve lines. Each line will contain the money she earned per 

month. Each number will be positive and displayed to the penny. No dollar sign will be 

included.

Output

The output will be a single number, the average of money she earned for the twelve 

months. It will be rounded to the nearest penny, preceded immediately by a dollar sign

without tail zero. There will be no other spaces or characters in the output.

Sample Input

2

100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

100.00

100.00

100.00

100.00

100.00

100.00

100.00

100.00

100.00

100.00

100.00

100.00

Sample Output

$1581.42

$100

比较水的一道题,就是求12个数的平均数。但加了一点小小的要求,。就是精确到2位小数,而且如果小数结尾有0,还要去掉

#include<stdio.h>
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int i;
double sum = 0;
for(i = 0; i < 12; i++)
{
double num;
scanf("%lf", &num);
sum += num;
}
char str[100];
sprintf(str, "%.2lf", sum / 12);
int j;
printf("$");
for(j= 0; str[j]; j++)
{
if(str[j] == '.')
{
if(str[j + 2] == '0')
{
if(str[j + 1] == '0')
break;
else str[j + 2] = 0;
}
}
putchar(str[j]);
}
printf("\n");
}
return 0;
}

最新文章

  1. Struts2之开山篇
  2. linux提取指定字符的行列并生成新文件(awk命令)
  3. [SoapUI] 同一个Resource不同参数时,在两个step里默认打开总是同一个Resource
  4. Is It A Tree?(并查集)
  5. genome MuSic安装
  6. C++求1!到n!的和
  7. vc/mfc获取rgb图像数据后动态显示及保存图片的方法
  8. [转] nodeJS的post提交简单实现
  9. IDEA系统提示中文乱码问题及解决
  10. mysql如何更新一个表中的某个字段值等于另一个表的某个字段值
  11. SQL点滴9—SQL Server中的事务处理以及SSIS中的内建事务
  12. BZOJ 3329: Xorequ [数位DP 矩阵乘法]
  13. 【java学习】Intelli Idea集成开发工具的使用
  14. 添加/删除/修改Windows 7右键的“打开方式”
  15. 201621123018《java程序设计》第14周作业总结
  16. linux命令学习——tar
  17. 5-11敏捷开发rails的章节: Rspec(使用方法) ,Slim(使用操作简介)
  18. SQL Serever学习8——数据表3
  19. DB DBS 和DBMS区别
  20. 04 关于oracle的锁的级别以及介绍

热门文章

  1. python有序查找算法:二分法
  2. 3 TKinter设置宽高及背景色
  3. centos6.5 安装iptables
  4. Spring boot配合Spring session(redis)遇到的错误
  5. 【Java安装】Centos6.8 安装Java1.6
  6. Hadoop:使用Mrjob框架编写MapReduce
  7. Linux命令详解nice
  8. LDAP过滤器使用说明(用户、组和容器的默认 LDAP 过滤器和属性)
  9. JavaScript权威指南 第二章 词法结构
  10. DBA_Oracle Sort排序处理空间耗用(概念)