Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy’s easy problem is that : give you the n,want you to find the n^n’s digital Roots.

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output

Output n^n’s digital root on a separate line of the output.

Sample Input

2

4

0

Sample Output

4

4

题意:输入一个数n,求n的n次方的数根。

数根:即某数字的每一位上的数字之和,如果和大于等于10,重复每一位上的数字之和,直到每一位上的数字之和是个位数。则这个个位数就是这个数字的数根。

九余数定理:

一个数对九取余,得到的数称之为九余数;

一个数的九余数 等于 它的各个数位上的数之和的九余数!

例:

5^5=3125

3+1+2+5=11

1+1=2(digital Roots)

3125%9=2;

一个数对9取余就等于它的个位数字之和对9取余就等于数根对9取余。

import java.util.Scanner;

public class Main{
public static void main(String[] args) {
Scanner sc= new Scanner(System.in);
while(sc.hasNext()){
int n = sc.nextInt();
if(n==0){
return ;
}
int m = 1;
for(int i=0;i<n;i++){
m=(m*n)%9;
}
if(m==0){
System.out.println(9);
}else{
System.out.println(m);
}
}
}
}

最新文章

  1. haha2
  2. C# webbrowser实现真正意义上的F5刷新
  3. 学Python后到底能干什么?
  4. 12-8下午 php语法
  5. 扩展欧几里德解的数量(51nod 1352)
  6. linux 文件删除原理
  7. javaweb-dbutils
  8. 决定如何开发你的WordPress主题框架
  9. 自定义标签体、MVC
  10. [国嵌笔记][008-009][远程登录Linux]
  11. Android开发学习之路--Camera之初体验
  12. Leetcode_136_Single Number
  13. Linux-ftp服务搭建
  14. 【整理】Java 8新特性总结
  15. shell 的多进程
  16. ASP 基础三 SQL指令
  17. 2017/2/5:oracle数据库的三大文件
  18. 泛型c#(深入理解c#)
  19. Kubernetes HPA
  20. electron demo项目npm install安装失败解决办法

热门文章

  1. 安卓(android)建立项目时失败,出现Android Manifest.xml file missing几种解决方法?(总结中)
  2. [转] shell文本字符串处理
  3. xheditor编辑器上传截图图片抓取远程图片代码
  4. android studio 的部分设置
  5. Configuring Network Configuration-RHEL7
  6. java的@see注释
  7. junit测试用例加载spring配置文件
  8. 安全管理:IE6安全隐患重重 为何不离不弃
  9. 传输层-TCP
  10. UI基本之UITextField相关方法属性