Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.

``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.

Output

Your program should output the sum of the VeryLongIntegers given in the input.

Sample Input

123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
#include<iostream>
#include<string.h>
using namespace std;
int main()
{
char a[1000];
int i,j,x;
while(cin>>a)
{
int sum[101]={0};
while(1)
{
int b[100]={0};
if(strcmp(a,"0")==0)
break;
int t=strlen(a);
x=99;
for(i=t-1;i>=0;i--)
b[x--]=a[i]-'0';
for(i=0;i<100;i++)
sum[i]+=b[i];
x=0;
for(i=99;i>=0;i--)
{
sum[i]+=x;
x=0;
if(sum[i]>9)
{
x=sum[i]/10;
sum[i]=sum[i]%10;
}
}
cin>>a;
}
for(i=0;i<100;i++)
{
if(sum[i]!=0)
break;
}
for(j=i;j<100;j++)
cout<<sum[j];
cout<<endl;
}
return 0;
}

最新文章

  1. 错误:违反并发性: DeleteCommand 影响了预期 1 条记录中的 0 条
  2. CTR预估评价指标介绍
  3. C# iis错误配置信息( 500.21 - Internal Server Error )
  4. XtraBackup安装
  5. leveldb 学习笔记之log结构与存取流程
  6. jQuery 学习之路(3):DOM操作
  7. JS正则表达式大全(整理详细且实用)
  8. [JAVA词形还原工具]Snowball
  9. 299. Bulls and Cows
  10. PHP中使用curlL实现GET和POST请求的方法
  11. nginx之服务器
  12. mysql 中文配置(转)
  13. CAD创建不规则形状视口
  14. robot framework-databaselibaray库使用(python)(转)
  15. MongoDB:利用官方驱动改装为EF代码风格的MongoDB.Repository框架 五 --- 为List&lt;MongoDBRef&gt;增加扩展方法
  16. Sql Server的艺术(二) SQL复杂条件搜索
  17. 最小化安装CentOS7的网卡设置
  18. setuptools安装和错误解决
  19. 基于Kurento的WebRTC移动视频群聊技术方案
  20. taro 报错及解决

热门文章

  1. Microsoft Azure 大计算 – 宣布收购 GreenButton
  2. uvalive5810 uva12368 Candles
  3. hdu 1210_(逻辑训练)
  4. Minimum Inversion Number(归并排序)
  5. NGINX 多个域名配置
  6. 关于bootstrap弹出二级对话框的使用
  7. Linux cd命令
  8. 【转】android权限列表
  9. 当cpu飙升时,找出php中可能有问题的代码行
  10. cocos2dx mac环境搭建