1063. Set Similarity

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers
shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed
by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers
in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

题目大意:输入n个集合,每个集合中有若干数,现在需要做k次查询,每次给出要比较的两个集合,要求计算出相似度 = Nc / Nt * 100%,其中Nc是两个集合的交集的大小,Nt是两个集合并集的大小。

主要思想:考虑到每一个集合中可能存在重复的数,而且需要做大量的查找操作(找并集时对集合a的每个元素判断是否存在于集合b),很容易想到stl库中的set容器,因为set中不存在重复元素,而且查找操作很快。对于每次查找操作,设置初始值nc为
0, nt 为集合 b 的大小,集合 a 的每个元素,如果存在于集合 b,则 nc+1;如果不存在,则 nt+1(注意:如果用两集合大小之和 减去 两集合交集大小 来计算 nt,可能会出现超时)。

#pragma warning(disable: 4786)
#include <cstdio>
#include <vector>
#include <set>
using namespace std;
int main(void) {
int n, i, j; scanf("%d", &n);
vector<set<int> > vec(n);
set<int>::iterator iter;
int m, num;
for (i = 0; i < n; i++) {
scanf("%d", &m);
for (j = 0; j < m; j++) {
scanf("%d", &num);
vec[i].insert(num);
}
}
int k, a, b;
scanf("%d", &k);
for (i = 0; i < k; i++) {
scanf("%d%d", &a, &b);
int nc = 0, nt = vec[b-1].size();
for (iter = vec[a-1].begin(); iter != vec[a-1].end(); iter++) {
if (vec[b-1].count(*iter)) //if (vec[b-1].find(*iter) != vec[b-1].end())
nc++;
else
nt++;
}
// nt = vec[a-1].size() + vec[b-1].size() - nc; //这样计算可能会超时
printf("%.1f%%\n", nc * 1.0 / nt * 100);
} return 0;
}

爬虫中的set容器解决这个问题就更容易了,& 和 | 分别对应交集和并集,唯一不足的就是有一个用例超时了。

n = int(input())
L1 = []
for i in range(n):
st = input()
L2 = st.split(' ')
L1.append(set(L2[1:]))
k = int(input())
for i in range(k):
pair = input().split(' ')
x, y = int(pair[0]), int(pair[1])
similarity = len(L1[x-1] & L1[y-1]) / len(L1[x-1] | L1[y-1]) * 100
print('%.1f%%' % (similarity)

最新文章

  1. iOS 动画组
  2. Hadoop程序运行中的Error(1)-Error: org.apache.hadoop.hdfs.BlockMissingException
  3. HTML 学习笔记 CSS3 (2D转换)
  4. WPF快速入门系列(3)——深入解析WPF事件机制
  5. Android开发环境搭建相关文章列表(转载)
  6. 实战1--应用EL表达式访问JavaBean的属性
  7. Python创建Cocos2d-x 2.2方法
  8. OpenStack 加入新的节点,创建虚拟机失败的问题
  9. Linux基本配置和管理 3 ---- Linux命令行文本处理工具
  10. NSTemporaryDirectory 临时文件
  11. 如何使用银联卡充值美元到BTC-E以及比特币搬砖教程
  12. os模块介绍
  13. vue脚手架搭建项目引用百度地图--出坑
  14. net start mysql意外终止1607
  15. Python 的几个命令行参数
  16. 转 python测试框架最全资源汇总
  17. MongoDB pymongo模块 删除数据
  18. Win10系列:VC++ Direct3D模板介绍3
  19. C++ AfxBeginThread的介绍/基本用法
  20. 视频基础知识:浅谈视频会议中H.264编码标准的技术发展

热门文章

  1. Vue移动端项目中下拉刷新和上拉加载
  2. 整整 Java 线程池
  3. windows服务程序的编写
  4. 细数阿里云在使用 Docker 过程中踩过的那些坑
  5. 华为设备RIP实施和理论详解
  6. python 多进程处理 multiprocessing模块
  7. Blog Customization
  8. Python爬虫(三)爬淘宝MM图片
  9. socket编程之并发回射服务器3
  10. lambda表达式入门详解