Battle Ships is a new game which is similar to Star Craft. In this game, the enemy builds a defense tower, which has L longevity. The player has a military
factory, which can produce N kinds of battle ships. The factory takes ti seconds to produce the i-th battle ship and this battle ship can make the tower loss li longevity every second when it
has been produced. If the longevity of the tower lower than or equal to 0, the player wins. Notice that at each time, the factory can choose only one kind of battle ships to produce or do nothing. And producing more than one battle ships of the same kind is
acceptable.

Your job is to find out the minimum time the player should spend to win the game.

Input

There are multiple test cases. 

The first line of each case contains two integers N(1 ≤ N ≤ 30) and L(1 ≤ L ≤ 330), N is the number of the kinds of Battle Ships, L is the longevity of the Defense Tower. Then the following N lines,
each line contains two integers i(1 ≤ i ≤ 20) and li(1 ≤ li ≤ 330) indicating the produce time and the lethality of the i-th kind Battle Ships.

Output

Output one line for each test case. An integer indicating the minimum time the player should spend to win the game.

Sample Input

1 1
1 1
2 10
1 1
2 5
3 100
1 10
3 20
10 100

Sample Output

2
4
5
这题比较难想到,看了题解后才恍然大悟。。这里把时间看做容量,所打怪物的血为价值,用dp[j]表示j这个时候最多能打怪物的血量,那么利用完全背包可以得到dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l[i]),其中dp[j-t[i]]是因为刚开始制造要花t[i]时间,后面指的是制造出来后的每一秒可以打多少血。

#include<stdio.h>
#include<string.h>
int max(int a,int b){
return a>b?a:b;
}
int dp[500];
int main()
{
int n,m=490,last,i,j;
int t[50],l[50];
while(scanf("%d%d",&n,&last)!=EOF)
{
for(i=1;i<=n;i++){
scanf("%d%d",&t[i],&l[i]);
}
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++){
for(j=t[i];j<=m;j++){
dp[j]=max(dp[j],dp[j-t[i]]+(j-t[i])*l[i]);
}
}
for(i=1;i<=m;i++){
if(dp[i]>=last){
printf("%d\n",i);break;
}
}
}
return 0;
}

最新文章

  1. Markdown资源 markd
  2. 64位gcc编译32位汇编
  3. 使用Jmeter测试MySQL性能——(1)连接配置
  4. Landsat 8 OLI_TIRS 卫星数字产品
  5. 基本的Web控件四
  6. [skill][gdb][coredump][abrt] 使用abrt管理程序coredump
  7. Dubbo源码解读:appendAnnotation [01]
  8. 虚拟机或真机调试React Native, 开启开发者菜单
  9. Mac下Intellij IDea发布JavaWeb项目 详解一 (1、新建JavaEE Project并进行相应设置 2、配置tomcat)
  10. CF576E Painting Edges
  11. MyBatis:2
  12. Thread 1 cannot allocate new log的问题分析 (转载)
  13. 【docker】docker启动、重启、关闭命令,附带:docker启动容器报错:docker: Error response from daemon: driver failed programming external connectivity on endpoint es2-node
  14. kcp协议详解
  15. X-code 描述文件的位置
  16. WPF实现的简单饼图
  17. Centos 安装 Oracle Java JDK
  18. Mac安装jee开发环境,webservice环境搭建
  19. codevs 1060 搞笑运动会 dp
  20. JS 利用正则表达式替换字符串

热门文章

  1. (二)数据源处理4-excel部分封装及数据转换
  2. Java开发手册之安全规约
  3. Linux 安装JDK配置环境(rpm安装和压缩版安装)
  4. Electron小白入门自学笔记(一)
  5. 攻防世界 - Crypto(一)
  6. CTFshow萌新赛-萌新福利
  7. ctfshow—web—web2
  8. Python 日志打印之自定义logger handler
  9. 关于redis搭建环境
  10. 研发流程 接口定义&amp;开发&amp;前后端联调 线上日志观察 模型变动