Periodic Strings 

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2
#include <cstdio>
#include <cstring>
using namespace std; int main()
{
int kases;
char s[100];
scanf("%d",&kases);
while (kases--)
{
scanf("%s",s);
int length = strlen(s);
for (int i = 1; i <= length; i++)
{ if (length%i == 0)
{
bool ok = true;
for (int j = i; j < length; j++)
if (s[j] != s[j%i])
{
ok = false;
break;
}
if (ok)
{
printf("%d\n",i);
break;
}
}
}
if (kases != 0)
printf("\n");
}
return 0;
}

本题没有难度,但由于没有认真审题,忽略了相邻两个输出之间要有空白行,提交了几次,认真审题是关键啊。

最新文章

  1. phalcon3.0.1默认多模块生成的几个bug
  2. FusionCharts和highcharts 饼图区别!
  3. python——常用功能之文本处理
  4. OSG addEventHandler W键 L键 F键
  5. 快速集成iOS基于RTMP的视频推流
  6. 23种设计模式学习一(单列模式)singleton
  7. HDU 2795 (线段树 单点更新) Billboard
  8. NSMutableParagraphStyle /NSParagraphStyle
  9. 直接通过浏览器打开Android App 应用
  10. jquery中push()的用法(数组添加元素)
  11. Swap file &quot;.Podfile.swp&quot; already exists!
  12. silentScroll() 滚屏
  13. DIP、IoC、DI以及IoC容器
  14. 手动写一个Servlet
  15. HttpURLConnection 411错误解决
  16. 去中心化类微博应用 mastodon
  17. 题解 P1801 【黑匣子_NOI导刊2010提高(06)】
  18. 用meterpreter实现跳板机
  19. 获取ArcMap窗口句柄,通过WinAPI获取工作空间中点击要素的系统桌面坐标实现窗体跟随
  20. js--单例设计模式

热门文章

  1. P1090 合并果子(JAVA语言)
  2. teprunner测试平台Django引入pytest完整源码
  3. MongoDB中“$”操作符表达式汇总
  4. Netflix业务运维分析和总结
  5. [深搜]C. 【例题3】虫食算
  6. [树形DP]没有上司的晚会
  7. Java第三章基础学习课后题练习
  8. 1.稀疏数组_java实现
  9. Linux+MicroPython+esp8233 YES!
  10. JDBC_14_使用JDBC工具类实现模糊查询