解题思路:给出n件物品,每买三件,折扣为这三件里面最便宜的那一件
即将n件物品的价值按降序排序,依次选择a[3],a[6],a[9]----a[3*k]

Shopaholic


Time Limit: 2 Seconds      Memory Limit: 65536 KB

Lindsay is a shopaholic. Whenever there is a discount of the kind where you can buy three items and only pay for two, she goes completely mad and feels a need to buy all items in the store. You have given up on curing her for this disease, but try to limit its effect on her wallet.

You have realized that the stores coming with these offers are quite selective when it comes to which items you get for free; it is always the cheapest ones. As an example, when your friend comes to the counter with seven items, costing 400, 350, 300, 250, 200, 150, and 100 dollars, she will have to pay 1500 dollars. In this case she got a discount of 250 dollars. You realize that if she goes to the counter three times, she might get a bigger discount. E.g. if she goes with the items that costs 400, 300 and 250, she will get a discount of 250 the first round. The next round she brings the item that costs 150 giving no extra discount, but the third round she takes the last items that costs 350, 200 and 100 giving a discount of an additional 100 dollars, adding up to a total discount of 350.

Your job is to find the maximum discount Lindsay can get.

Input

The first line of input gives the number of test scenarios, 1 <= t <= 20. Each scenario consists of two lines of input. The first gives the number of items Lindsay is buying, 1 <= n <= 20000. The next line gives the prices of these items, 1 <= pi <= 20000.

Output

For each scenario, output one line giving the maximum discount Lindsay can get by selectively choosing which items she brings to the counter at the same time.

Sample Input

1 6 400 100 200 350 300 250

Sample Output

400

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[20005];
int cmp(int a,int b)
{return a>b;} int main()
{
int ncase,n,i,ans;
scanf("%d",&ncase);
while(ncase--)
{
ans=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
sort(a+1,a+n+1,cmp);
for(i=1;i<=n/3;i++)
ans+=a[3*i];
printf("%d\n",ans);
}
}

  

最新文章

  1. 一个粗心的Bug,JSON格式不规范导致AJAX错误
  2. Zookeeper的安装和使用
  3. C#泛型代理、泛型接口、泛型类型、泛型方法
  4. python 版本升级(CentOS) 从2.6.6升级到2.7.6
  5. DeviceFamily XAML Views(一)
  6. redis 问题解决(MISCONF Redis is configured to save RDB snapshots)
  7. VB中WinSock控件的属性、方法、事件及应用
  8. LeetCode:Path Sum I II
  9. iOS边练边学--NSURLSession、NSURLSessionTask的介绍与使用以及url中包含了中文的处理方法
  10. bitmap格式分析
  11. Java之获取系统属性
  12. 批量转换word文档到pdf文件
  13. Unity3D RPC调用顺序问题
  14. 【.NET】使用HtmlAgilityPack抓取网页数据
  15. C#类的初始化
  16. 【linux之简介】
  17. 清理out的浏览器收藏夹发现的
  18. Eclipse4JavaEE安装SpringBoot
  19. PS扣签名
  20. ffmpeg中AVOption的实现分析

热门文章

  1. 理解HashMap底层原理,一个简单的HashMap例子
  2. surfaceView实现拍照功能
  3. quartz定时任务框架调度机制解析
  4. k8s集群启动了上万个容器(一个pod里放上百个容器,起百个pod就模拟出上万个容器)服务器超时,无法操作的解决办法
  5. 【Django】遇到的问题
  6. node——try-catch与异步操作
  7. C#追加、拷贝、删除、移动文件、创建目录、递归删除文件夹及文件
  8. 02 C#高级
  9. Jmeter中模拟多用户执行多场景操作
  10. 紫书 例题8-1 UVa 120(构造法)