Some DNA sequences exist in circular forms as in

the following gure, which shows a circular sequence

\CGAGTCAGCT", that is, the last symbol \

T

" in

\

CGAGTCAGCT

" is connected to the rst symbol \

C

". We al-

ways read a circular sequence in the clockwise direction.

Since it is not easy to store a circular sequence in a com-

puter as it is, we decided to store it as a linear sequence.

However, there can be many linear sequences that are ob-

tained from a circular sequence by cutting any place of the

circular sequence. Hence, we also decided to store the linear

sequence that is lexicographically smallest among all linear

sequences that can be obtained from a circular sequence.

Your task is to nd the lexicographically smallest sequence

from a given circular sequence. For the example in the gure,

the lexicographically smallest sequence is \

AGCTCGAGTC

". If there are two or more linear sequences that

are lexicographically smallest, you are to nd any one of them (in fact, they are the same).

Input

The input consists of

T

test cases. The number of test cases

T

is given on the rst line of the input

le. Each test case takes one line containing a circular sequence that is written as an arbitrary linear

sequence. Since the circular sequences are DNA sequences, only four symbols, `

A

', `

C

', `

G

' and `

T

', are

allowed. Each sequence has length at least 2 and at most 100.

Output

Print exactly one line for each test case. The line is to contain the lexicographically smallest sequence

for the test case.

Sample Input

2

CGAGTCAGCT

CTCC

Sample Output

AGCTCGAGTC

CCCT

//思路:利用strcmp函数比较字典序,如果找到小的就复制过去,然后将节点向后移一位,继续比较;

#include<iostream>
#include<algorithm>
#include<string>
#include<cmath>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
char s[110],s1[110];
int t;
cin>>t;
while(t--)
{
cin>>s;
int l=strlen(s);
strcpy(s1,s); //先将s复制到s1数组
for(int i=0;i<l;i++)
{
char lastc=s[l-1]; //最后一个字符,待会儿赋值给s[0]
for(int j=l-1;j>0;j--)
s[j]=s[j-1]; //相当于往后断开一个节点
s[0]=lastc;
if(strcmp(s,s1)<0) //如果新串字典序较小,复制给s1
strcpy(s1,s);
}
cout<<s1<<endl;
}
return 0;
}

标程:

#include<stdio.h>
#include<string.h>
#define maxn 105 // 环状串s的表示法p是否比表示法q的字典序小
int less(const char* s, int p, int q) {
int n = strlen(s);
for(int i = 0; i < n; i++)
if(s[(p+i)%n] != s[(q+i)%n])
return s[(p+i)%n] < s[(q+i)%n];
return 0; // 相等
} int main() {
int T;
char s[maxn];
scanf("%d", &T);
while(T--) {
scanf("%s", s);
int ans = 0;
int n = strlen(s);
for(int i = 1; i < n; i++)
if(less(s, i, ans)) ans = i;
for(int i = 0; i < n; i++)
putchar(s[(i+ans)%n]);
putchar('\n');
}
return 0;
}

最新文章

  1. fastjson解析json,model字段有顺序要求吗
  2. java - Stack栈和Heap堆的区别
  3. __attribute__ 变量对齐
  4. 使用PHP搭建书虫网站
  5. 微软职位内部推荐-Software Engineer II-Office Incubation
  6. 【转】Android 异步消息处理机制 让你深入理解 Looper、Handler、Message三者关系
  7. sqlserver2005数据库18456错误(转)
  8. 【转】Java ConcurrentModificationException异常原因和解决方法
  9. 超酷的jQuery百叶窗图片滑块实现教程
  10. JavaWeb之多语言国际化
  11. Apache Beam 剖析
  12. 解决SQL Server 阻止了对组件 &#39;Ad Hoc Distributed Queries&#39; 的 STATEMENT &#39;OpenRowset/OpenDatasource&#39; 的访问
  13. angular6 开发实践基础知识汇总
  14. [NIO-3]Socket通道
  15. 在Amazon FreeRTOS V10中使用运行时统计信息
  16. 完整部署CentOS7.2+OpenStack+kvm 云平台环境(2)--云硬盘等后续配置
  17. beego的https和http同时启用
  18. css引入外部字体使网站字体更美观
  19. UWP 响应键盘组合快捷键
  20. 学习笔记:Maven的ArcheType的学习笔记

热门文章

  1. Bash 如何取得当前正在执行的脚本的绝对路径?
  2. kfka学习笔记一:使用Python操作Kafka
  3. PatentTips - Optimizing power usage by factoring processor architectural events to PMU
  4. MySQL 函数大全及用法示例
  5. Android开发之使用BroadcastReceiver实现开机自己主动启动(源码分享)
  6. ORM进阶之Hibernate中对象的三大状态解析
  7. MySql 基础学习笔记 1——概述与基本数据类型: 整型: 1)TINYINT 2)SMALLINT 3) MEDIUMINT 4)INT 5)BIGINT 主要是大小的差别 图 浮点型:命令
  8. 利用ajax异步处理POST表单中的数据
  9. 经验总结21--抓取WEB数据,汇率,HtmlAgilityPack
  10. [IOS]mac以太网连接