Stealing Harry Potter's Precious

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1875    Accepted Submission(s): 878

Problem Description
  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows
such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left
room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:








  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious
are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access
the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from
one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.
 
Input
  There are several test cases.

  In each test cases:

  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).

  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.

  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.

  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).

  The input ends with N = 0 and M = 0
 
Output
  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.
 
Sample Input
2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0
 
Sample Output
-1
5
 
Source
这题有些人用什么压缩dp写的,俺不会,后来发现一种超级巧妙的方法
你看啊k最多总共仅仅有4个点增加a1,a2,a3,a4,起点是a0,那么从a0一直遍历全部点不就是a0->a1->a2-》a3->a4的a1,a2,a3,a4的全排列吗,最多4!直接爆力,每次用next_permutaion()更新排列就可以。当天假设k比較大这样的方法不行
还有注意next_permuation(a,a+n)假设你是从下标1開始的就是(a+1,a+n+1)不然会一直WA!
#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
#include <algorithm>
using namespace std; int n , m,k; int visit[110][110];
int p[5];
char g[110][110];
int sx,sy;
int dx[] = {-1,1,0,0};
int dy[] = {0,0,-1,1}; struct node
{
int x,y,step;
node(int a,int b, int c): x(a),y(b),step(c) {}
node(){}
}ss[6]; int bfs()
{
queue<node> q;
q.push(node(sx,sy,0));
memset(visit,0,sizeof(visit)); visit[sx][sy] = 1; for(int i = 0; !q.empty(); )
{ node temp = q.front();
q.pop(); for(int j = 0; j < 4; j++)
{
int xx = temp.x + dx[j];
int yy = temp.y + dy[j];
int step = temp.step + 1; if(xx < 0 || yy < 0 || xx >= n || yy >= m || g[xx][yy] == '#' || visit[xx][yy]) continue; int flag = xx == ss[p[i]].x && yy == ss[p[i]].y;
if(flag)
{
while(!q.empty()) q.pop();
memset(visit,0,sizeof(visit));
if(++i == k) return step;
} q.push(node(xx,yy,step));
visit[xx][yy] = 1;
if(flag) break;
}
} return -1;
}
int main()
{
#ifdef xxz
freopen("in.txt","r",stdin);
#endif while(scanf("%d%d",&n,&m)!=EOF && n != 0)
{
for(int i = 0; i < n; i++)
{
scanf("%s",g[i]);
for(int j = 0; j < m; j++)
{
if(g[i][j] == '@')
{
sx = i;
sy = j;
}
}
} scanf("%d",&k);
int Case = 1;
for(int i = 0; i < k; i++)
{
scanf("%d%d",&ss[i].x,&ss[i].y);
ss[i].x--;
ss[i].y--;
p[i] = i; Case *= i+1;
} int ans = -1;
while(Case--)
{
int temp = bfs();
// cout<<temp<<endl;
if(temp > -1 && (temp < ans || ans == -1)) ans = temp;
next_permutation(p,p+k);
}
printf("%d\n",ans);
}
return 0;
}

 

最新文章

  1. NodeOS操作系统
  2. SortedMap接口
  3. 使用ASP.NET Web Api构建基于REST风格的服务实战系列教程【外传】——Attribute Routing
  4. mysql设置密码
  5. C++学习笔记35:函数模板
  6. CentOS FireFox Flash Player
  7. PHP中的函数声明与使用
  8. 内连接、左外连接、右外连接、全外连接、交叉连接(CROSS JOIN)-----小知识解决大数据攻略
  9. MySQL创建新用户以及ERROR 1396 (HY000)问题解决
  10. [工作积累] Tricks with UE4 PerInstanceRandom
  11. android adb命令 抓取系统各种 log
  12. python Rpyc简单使用
  13. Qt绘制字体并获取文本宽度
  14. bip39
  15. 2.1《想成为黑客,不知道这些命令行可不行》(Learn Enough Command Line to Be Dangerous)——重定向文件和添加文件
  16. u-boot2011.09 u-boot.img 的流程跟踪
  17. No.16 selenium学习之路之异常处理
  18. CentOS7.5搭建ELK6.2.4集群及插件安装
  19. jQuery中的观察者模式(Observer Pattern)
  20. Accounting_会计电算化工作指南

热门文章

  1. 使用PyCharm安装第三方库
  2. 常见c#正则表达式类学习整理
  3. Jquery获取select选中的option的文本信息
  4. VPS 的 CentOS6 升级 Python 的方法
  5. AVCaptureSession音频视频采集
  6. svd 奇异值分解
  7. ECMall 25个 数据库表 说明文档
  8. 软件——keil的查找,错误,不能跳转到相应的行
  9. 【Struts2三】拦截器
  10. 第一个hello word 驱动载入失败--------