Transmitters


Time Limit: 2 Seconds      Memory Limit: 65536 KB


In a wireless network with multiple transmitters sending on the same frequencies, it is often a requirement that signals don't overlap, or at least that they don't conflict. One way of
accomplishing this is to restrict a transmitter's coverage area. This problem uses a shielded transmitter that only broadcasts in a semicircle.



A transmitter T is located somewhere on a 1,000 square meter grid. It broadcasts in a semicircular area of radius r. The transmitter may be rotated any amount, but not moved. Given N points anywhere on the grid, compute the maximum number of points that can
be simultaneously reached by the transmitter's signal. Figure 1 shows the same data points with two different transmitter rotations.

All input coordinates are integers (0-1000). The radius is a positive real number greater than 0. Points on the boundary of a semicircle are considered within that semicircle. There are 1-150 unique points to examine per transmitter. No points are at the same
location as the transmitter.



Input consists of information for one or more independent transmitter problems. Each problem begins with one line containing the (x,y) coordinates of the transmitter followed by the broadcast radius, r. The next line contains the number of points N on the grid,
followed by N sets of (x,y) coordinates, one set per line. The end of the input is signalled by a line with a negative radius; the (x,y) values will be present but indeterminate. Figures 1 and 2 represent the data in the first two example data sets below,
though they are on different scales. Figures 1a and 2 show transmitter rotations that result in maximal coverage.



For each transmitter, the output contains a single line with the maximum number of points that can be contained in some semicircle.

Example input:



25 25 3.5

7

25 28

23 27

27 27

24 23

26 23

24 29

26 29

350 200 2.0

5

350 202

350 199

350 198

348 200

352 200

995 995 10.0

4

1000 1000

999 998

990 992

1000 999

100 100 -2.5

Example output:



3

4

4


题意:用一个固定圆心坐标和半径的半圆去覆盖点,问最多能覆盖的数量

#include <bits/stdc++.h>
using namespace std;
const int N = 205; int x, y;
double r;
int n; int ax[N],ay[N]; int num1,num2; void fun(int i,int j)
{
int tmp=(ax[i]-x)*(ay[j]-y)-(ax[j]-x)*(ay[i]-y);
//两个向量的叉积。a=(x1,y1) b=(x2,y2)
//c=a X b=x1*y2-x2*y1
//假设c>0。表示向量a逆时针到向量b小于PI
//假设c<0,表示向量a顺时针到向量b小于PI
if(tmp==0)
{
num1++;
num2++;
}
else if(tmp>0)
num1++;
else
num2++;
} int main()
{
while(~scanf("%d%d%lf",&x,&y,&r))
{
if(r<0) break; scanf("%d",&n);
int cnt=0;
int a,b; for(int i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
if((a-x)*(a-x)+(b-y)*(b-y)>r*r) continue;
ax[cnt]=a;ay[cnt++]=b;
} int ans=0; for(int i=0;i<cnt;i++)
{
num1=0;
num2=0; for(int j=0;j<cnt;j++)
{
fun(i,j);
}
ans=max(ans,num1);
ans=max(ans,num2);
} printf("%d\n",ans); } return 0;
}

最新文章

  1. 从tabBarController的一个item上的控制器跳转到另一个item上的控制器
  2. Spark Streaming源码解读之Driver中ReceiverTracker架构设计以具体实现彻底研究
  3. 微信封号浪潮再起 A货假代购还能在朋友圈泛滥多久?
  4. Liferay 6.2 改造系列之二十二:如何发布WAR包
  5. 洛谷 P1991 无线通讯网 Label:最小生成树 || 二分
  6. 《C与指针》第三章练习
  7. Django 源码小剖: Django 对象关系映射(ORM)
  8. http://blog.csdn.net/jun55xiu/article/details/43051627
  9. view class source code with JAD plugin in Eclipse
  10. 使用otl,报错:mysql Commands out of sync; you can&#39;t run this command now
  11. (21)odoo中的QWeb模板引擎
  12. Mouse_event 鼠标点击
  13. sql server 分布式事务
  14. 浅谈二维RMQ
  15. 【译】Optimize caching-缓存优化
  16. UVa1583 Digit Generator
  17. android GifView分享
  18. AJAX获取JSON WEB窗体代码
  19. 前端面试题---vue部分
  20. Golang 类型转换,断言和显式强制转换

热门文章

  1. 【USACO2006 Mar】滑雪缆车 skilift
  2. Coursera公开课-Machine_learing:编程作业7
  3. &lt;form&gt; 标签
  4. SQL基本操作——JOIN多表联查
  5. [Windows Server 2012] 服务器安全加固
  6. SQL server 2005中无法新建作用(Job)的问题
  7. Nginx 监控
  8. id 转 entity
  9. Mirror用法
  10. 洛谷——P1122 最大子树和