In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)

Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).

Output Specification:

For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.

Sample Input 1:

7 12

5 7

1 2

1 3

2 3

2 4

3 4

5 2

7 6

6 3

4 5

6 4

5 6

Sample Output 1:

2 4 4 4 4 4 2

Eulerian

Sample Input 2:

6 10

1 2

1 3

2 3

2 4

3 4

5 2

6 3

4 5

6 4

5 6

Sample Output 2:

2 4 4 4 3 3

Semi-Eulerian

Sample Input 3:

5 8

1 2

2 5

5 4

4 1

1 3

3 2

3 4

5 3

Sample Output 3:

3 3 4 3 3

Non-Eulerian

#include<iostream> //注意检查连通性
#include<vector>
using namespace std;
int cnt=0;
vector<vector<int>> graph;
vector<int> visited(501, 0);
void dfs(int s){
visited[s]=1;
cnt++;
for(int i=0; i<graph[s].size(); i++)
if(visited[graph[s][i]]==0)
dfs(graph[s][i]);
}
int main(){
int vn, en, even=0;
cin>>vn>>en;
vector<int> degrees(vn+1, 0);
graph.resize(vn+1);
for(int i=0; i<en; i++){
int v1, v2;
cin>>v1>>v2;
graph[v1].push_back(v2);
graph[v2].push_back(v1);
degrees[v1]++;
degrees[v2]++;
}
dfs(1);
for(int i=1; i<=vn; i++){
i==1?cout<<degrees[i]:cout<<" "<<degrees[i];
even=(degrees[i]%2==0?even:even+1);
}
cout<<endl;
if(even==0&&cnt==vn)
cout<<"Eulerian"<<endl;
else if(even==2&&cnt==vn)
cout<<"Semi-Eulerian"<<endl;
else
cout<<"Non-Eulerian"<<endl;
return 0;
}

最新文章

  1. Entity Framework 中的Code First 中引入数据库函数
  2. maven 检查依赖冲突和版本冲突
  3. Yii2框架与MongoDB拓展、Redis拓展的安装流程
  4. Android 使用版本控制工具时添加忽略文件方式
  5. 设置segue跳转页面
  6. __int64 与long long 的区别 分类: Brush Mode 2014-08-14 10:22 64人阅读 评论(0) 收藏
  7. 【HDOJ】1074 Doing Homework
  8. DOM Traversal Example | Documentation | Qt Project
  9. HH的军训(容斥)
  10. UI_UIImageView 基本操作
  11. jQuery小测的总结
  12. BZOJ 1029: [JSOI2007]建筑抢修【优先队列+贪心策略】
  13. Codeforces 1108E2 Array and Segments (Hard version)(差分+思维)
  14. UOJ#110. 【APIO2015】Bali Sculptures 贪心 动态规划
  15. zabbix 监控第三方网络
  16. LeetCode算法题-Ransom Note(Java实现)
  17. mysql授权远程访问
  18. noip第17课资料
  19. TortoiseSVN checkout 之后图标(绿色勾之类的)没有显示出来的问题
  20. Druid的Segment Balance及其代价计算函数分析

热门文章

  1. COCI2012 TOY
  2. 准确率,精确率,召回率,F-measure 之间的关系
  3. c++ class does not name a type (转载)
  4. js的多种数值分类相加,数据先后没有顺序,不确定同类数据多少
  5. js最全的十种跨域解决方案
  6. 在CentOS下安装VMware tool
  7. jquery实现文字自动向上滚动,鼠标放上去停止,移开继续滚动代码...
  8. 全面学习ORACLE Scheduler特性(12)使用Windows和Window Groups
  9. SpringBoot-redis-session
  10. Position属性四个值:static、fixed、absolute和relative的区别