poj——2771    Guardian of Decency
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 5916   Accepted: 2458

Description

Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates a low probability two persons will become a couple:

  • Their height differs by more than 40 cm.
  • They are of the same sex.
  • Their preferred music style is different.
  • Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting).

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information. 

Input

The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated data items:

  • an integer h giving the height in cm;
  • a character 'F' for female or 'M' for male;
  • a string describing the preferred music style;
  • a string with the name of the favourite sport.

No string in the input will contain more than 100 characters, nor will any string contain any whitespace. 

Output

For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.

Sample Input

2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output

3
7

Source

题目大意:

题意:现在有一个老师想带领他的学生出去郊游,但是他非常担心在郊游的过程中有些学生会发生恋爱关系,而他认为发生恋爱关系的可能性比较小的判断标准有以下四个,如果满足四个条件中的任何一个,即被他认为可能发生恋爱关系的可能性比较小:

            1>两人身高的差距超过40cm;
            2>两人性别相同;
            3>两人所喜欢的音乐风格不同;
            4>两人最喜爱的运动相同;

现在给出n个学生,并给出每个学生的信息(信息为:身高 性别 所喜欢的音乐风格 喜爱的运动),要求求解最大可以带出去郊游的学生数.

思路:
由于两个女生一定不会发生恋爱关系(此处我们不考虑性取向有问题的情况(ORZ)),所以我们可以以该同学的性别为根据来建立二分图。
然后我们在判断两边的同学是否满足上述情况,若满足则连边。然后对于我们建出的这个图在求最大匹配。这样我们就转化成了裸地匈牙利算法。最多可以带的学生数=总学生数-最大匹配数。
注意:char不能用==直接比,这样比出来的只是第一个字符,而非全部,我们这里要用strcmp比较两个字符的大小,这两个字符的字典序如果相同则返回0,如果第一个字符的字典序大返回1,反之,返回-1。
代码:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
#define N 510
using namespace std;
char ch;
bool vis[N];
int t,n,x,ans,gnum,bnum,pre[N],map[N][N];
struct nn
{
    int h;
    ];
    ];
}girl[N],boy[N];
int read()
{
    ,f=;char ch=getchar();
    ; ch=getchar();}
    +ch-'; ch=getchar();}
    return x*f;
}
void add_edge()
{
    ;i<=bnum;i++)
     ;j<=gnum;j++)
      )
        map[i][j]=;
}
int find(int x)
{
    ;i<=gnum;i++)
     if(!vis[i]&&map[x][i])
     {
         vis[i]=true;
         ||find(pre[i]))
         {
             pre[i]=x;
             ;
         }
     }
    ;
}
int main()
{
    t=read();
    while(t--)
    {
        ans=;bnum=,gnum=;
        memset(boy,,sizeof(boy));
        memset(girl,,sizeof(girl));
        memset(pre,,sizeof(pre));
        memset(map,,sizeof(map));
        n=read();
        ;i<=n;i++)
        {
            x=read(); scanf("%c",&ch);
            if(ch=='F')
            {
                girl[++gnum].h=x;
                cin>>girl[gnum].fm;
                cin>>girl[gnum].fs;
            }
            else
            {
                boy[++bnum].h=x;
                cin>>boy[bnum].fm;
                cin>>boy[bnum].fs;
            }
        }
        add_edge();
        ;i<=bnum;i++)
        {
            memset(vis,,sizeof(vis));
            if(find(i)) ans++;
        }
        printf("%d\n",n-ans);
    }
    ;
}
 

最新文章

  1. Linux测试环境搭建的学习建议
  2. JavaSe:ThreadLocal
  3. Java学习手记1——集合
  4. wxPython+Boa Constructor环境配置
  5. eclipse 清楚git记录的密码
  6. paper 78:sniff抓包程序片段
  7. git跨平台换行符不兼容
  8. opennebula kvm attach disk
  9. Opencv on Ubuntu (from Ubuntu)
  10. node.js作为“简单HTTP服务器”
  11. python面试题整合
  12. [Swift]LeetCode219. 存在重复元素 II | Contains Duplicate II
  13. scala读取配置文件
  14. Spring Boot(三):AOP&amp;日志操作&amp;异常处理
  15. python3+selenium框架设计07-unittest单元测试框架
  16. CSS矩形盒子的四个边界
  17. JS-两周内自动登录功能
  18. Shiro和Spring 集合实现同一个账号只能一个人在线使用,其它人在使用进行剔除(八)
  19. C#画个控件,指定字符特殊颜色显示
  20. 天梯赛 L2-010 排座位 (并查集)

热门文章

  1. 原生js的容易忽略的相似点(二)
  2. uva1612 Guess
  3. es 集群部署
  4. 跑RFCN
  5. java登录拦截Filter
  6. sublime中使用markdown并实时编辑
  7. POJ-1190 蛋糕问题
  8. c++类流操作运算符的重定义
  9. [LUOGU] P2704 炮兵阵地
  10. (7) openssl dgst(生成和验证数字签名)