Rescue

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 60   Accepted Submission(s) : 22
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.



Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.



You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 
Input
First line contains two integers stand for N and M. Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. Process to the end of the file.
 
Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
 
Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........
 
Sample Output
13
 
 
 
 
 
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
#define N 210
using namespace std;
char a[N][N];
int b[N][N];
int n,m,ax,ay;
int dx[4]={0,1,-1,0};
int dy[4]={1,0,0,-1};
struct zz
{
int x,y,ans;
friend bool operator<(zz x,zz y)
{
return x.ans>y.ans;/*按照时间从小到大排序*/
}
};
void bfs(int x,int y)
{
memset(b,0,sizeof(b));
priority_queue<zz>q;
zz f1,f2;
f1.x=x;f1.y=y;
f1.ans=0;/*第一部一定要让ans=0*/
q.push(f1);
b[x][y]=1;
while(!q.empty())
{
f1=q.top() ;
q.pop();
if(a[f1.x][f1.y]=='r')
{
printf("%d\n",f1.ans);
return ;
}
for(int i=0;i<4;i++)
{
f2.x=f1.x+dx[i];
f2.y=f1.y+dy[i];
if(f2.x>0&&f2.x<=n&&f2.y>0&&f2.y<=m&&!b[f2.x][f2.y]&&a[f2.x][f2.y]!='#')
{/*没有越界不是墙壁没有被用过的点执行下一步操作*/
b[f2.x][f2.y]=1;
if(a[f2.x][f2.y]=='x')
f2.ans=f1.ans+2;/*遇到x时间加1*/
else
f2.ans=f1.ans+1;
q.push(f2);
}
}
}
printf("Poor ANGEL has to stay in the prison all his life.\n");/*当遍历一遍之后还未找到人r*/
}
int main(){
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
scanf("%s",a[i]+1);
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
if(a[i][j]=='a')
{
ax=i;ay=j;/*找到a的坐标*/
}
}
}
bfs(ax,ay);
}
return 0;
}

最新文章

  1. 来,一起让我们越来越懒,面向CSS、JS未来编程。(9.28已更新)
  2. win7不能在同一窗口打开文件夹,如何解决
  3. JAVA的Date类与Calendar类【转】
  4. MongoDB驱动之Linq操作
  5. eclipse中新建python项目报错:Project interpreter not specified
  6. 一张图说明该选用神马程式来serve你的django应用
  7. Using SSH on Linux
  8. 【转】CppUnit使用简介
  9. BZOJ 1046 上升序列
  10. c++ 依据输入动态声明数组(一维,二维)
  11. JSON 数字排序 多字段排序
  12. 本地jar上传到本地仓库
  13. 浅谈C#中的斐波拉契数列
  14. 【转载】Ubuntu 12.04 LTS 中文输入法的安装
  15. git只追踪特定类型的文件
  16. 启动matlab时总是直接跳转到安装界面的解决方案
  17. 寄存器理解 及 X86汇编入门
  18. mysql(5.7以上)查询报错:ORDER BY clause is not in GROUP BY..this is incompatible with sql_mode=only_full_group_by
  19. highchart应用示例2-上:圆角柱状图,下:多指标曲线图
  20. pip指定网址安装

热门文章

  1. 5.13redis的相关基础
  2. (转)vuex2.0 基本使用(2) --- mutation 和 action
  3. 青橙 M4 解锁BootLoader 并刷入recovery ROOT
  4. android学习-第二讲(修改项目名称和图标,log,过滤器)
  5. QS之force(1)
  6. js与Jquery的对比
  7. Postgresql_最新版11.2源码编译安装
  8. jupyter notebook主目录修改
  9. CSS学习笔记之基本介绍
  10. 11. IDEA 在同一工作空间创建多个项目