Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7795   Accepted: 4136

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤ i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

 
题解:
f[i][j]表示i到j的最大括号匹配数
 
#include <iostream>
#include<cstdio>
#include<cstring>
#include<map>
#include<set>
#include<queue>
#include<vector>
#include<deque>
#include<algorithm>
#include<string>
#include<stack>
#include<cmath>
using namespace std;
char ch[];
int dp[][];
int n;
bool ok(int x,int y)
{
if (ch[x]=='(' && ch[y]==')') return ;
if (ch[x]=='[' && ch[y]==']') return ;
return ;
} int main()
{
while(~scanf("%s",&ch))
{
if (ch[]=='e') break;
n=strlen(ch);
memset(dp,,sizeof(dp));
// for(int i=0;i<n;i++)
// for(int j=i+1;j<n;j++) 正就是不对的
for(int i=n-;i>=;i--)
for(int j=i+;j<n;j++)
{
if (ok(i,j)) dp[i][j]=max(dp[i][j],dp[i+][j-]+);
for(int k=i;k<=j;k++)
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]); }
printf("%d\n",dp[][n-]); }
return ;
}

最新文章

  1. ASP.NET-DataList控件-DataList嵌套
  2. MySQL 表分区详解MyiSam引擎和InnoDb 区别(实测)
  3. Mware vCenter Server 识别固态硬盘为(非SSD)是什么原因?
  4. CSU 1503 点到圆弧的距离(2014湖南省程序设计竞赛A题)
  5. iOS应用架构谈(二):View层的组织和调用方案(上)
  6. 复制到剪贴板的JS实现--ZeroClipboard (兼解决IE下兼容问题)
  7. Processes vs Threads
  8. Javascript中关于数组的认识
  9. jquery登录验证插件
  10. [C++]Saving the Universe——Google Code Jam Qualification Round 2008
  11. js继承之原型链方式实现
  12. Unity 捏脸整理及基于骨骼的捏脸功能实现
  13. gulp+tp5配置
  14. 函数语法:currentStyle、getComputedStyle兼容判断
  15. js删除数组中元素 delete 和splice的区别
  16. windows 查看端口是否被占用
  17. leetcode数据库题目及答案汇总
  18. es6入门4--promise详解
  19. C#如何实现类似QQ那样靠边隐藏的功能
  20. 大纲2.3 Internet

热门文章

  1. curl 命令返回json结构human readable
  2. configparser模块来生成和修改配置文件
  3. Hbase Region Server整体架构
  4. 20145316《Java程序设计》实验一:Java开发环境的熟悉(Windows + IDEA)
  5. java单例模式之懒汉式分析
  6. 在python3下使用OpenCV 抓取摄像头图像并实时显示3色直方图
  7. MySQL的索引是什么?怎么优化?
  8. C/C++中RAND_MAX的用法
  9. libevent库介绍--事件和数据缓冲
  10. Python3.6 安装、后续终端pip 安装模块命令