Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 39532    Accepted Submission(s): 16385

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?



 
Input
The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.
 
Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 
Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1
 
Sample Output
14
 

题解:

裸的01背包,经典例题。

參考代码:

#include<stdio.h>
#define M 1111
#include<string.h>
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int t,a[M],b[M],dp[M];
scanf("%d",&t);
while(t--)
{
int n,v;
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&v);
for(int i=0;i<n;i++)
scanf("%d",&b[i]);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<n;i++)
{
for(int j=v;j>=a[i];j--)
{
dp[j]=max(dp[j],dp[j-a[i]]+b[i]);
}
}
printf("%d\n",dp[v]);
}
return 0;
}

最新文章

  1. String转double或者float会有精度丢失的问题
  2. 51nod 1040最大公约数和(欧拉函数)
  3. Jquery Data Table插件
  4. UVA1220Party at Hali-Bula(树的最大独立集 + 唯一性判断)
  5. eclipse打jar包步骤
  6. write() ,read();
  7. CSS浏览器兼容性----Hack
  8. hadoop_并行写操作思路
  9. Best jQuery Plugins of the Month – May 2014
  10. java中volatile的简单理解
  11. 总结Ajax验证注册功能的两种方式
  12. Spring Boot + Vue 前后端分离,两种文件上传方式总结
  13. 一些优秀的Python包
  14. java学习--面向对象
  15. django时间的时区问题(转)
  16. Axure 第一次接触动态面板
  17. MongoDB中的变更通知
  18. thinkphp中url的生成U()方法
  19. Scala 将BigDecimal转换为Long
  20. AppDelegate生命周期回调顺序

热门文章

  1. redis学习(二)redis.conf文件配置
  2. 【转】 Linux中记录终端输出到txt文本文件
  3. PowerDesigner 中将Comment(注释)及Name(名称)内容互相COPY的VBS代码
  4. linux的进程管理
  5. 自定义的类型放入STL的set中,需要重载自定义类中的“&lt;”符号(转)
  6. 使用p6spy格式化日志输出
  7. Android,一条线串联实心圆布局
  8. P1450 包裹快递 RP+14【二分】
  9. 好用的 HTTP模块SuperAgent
  10. 使用springboot 2.0后,静态资源默认路径无法访问