Description

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

这题直接想到了思路1A了。

假设f(n)表示以a[n]结尾的子区间互异数的和的和。对于f(n-1),可能会有两部分组成,一部分是包含a[n]这个值的A,一部分是不包含a[n]这个值的B,假设B由p个区间加和。那么可以得到:f(n) = A + B + p*a[n] = f(n-1) + p*a[n]。所以关键是求p。

而由于f(n-1)是以a[n-1]结尾的子区间互异数的和,必然的,假设a[i]是距离a[n]最近的值为a[n]的数,则p = n-i。于是只需要记录最近出现值k的脚标即可。这里采用了map,数据范围不是非常大,也可以直接开数组。

代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <set>
#include <map>
#include <queue>
#include <string>
#define LL long long using namespace std; int main()
{
//freopen("test.in", "r", stdin);
int T, n, v, k;
LL ans, f;
scanf("%d", &T);
for (int times = 0; times < T; ++times)
{
scanf("%d", &n);
map<int, int> s;
ans = 0;
f = 0;
for (int i = 1; i <= n; ++i)
{
scanf("%d", &v);
f = f + (i-s[v])*v;
s[v] = i;
ans += f;
}
printf("%lld\n", ans);
}
return 0;
}

最新文章

  1. Android 手机卫士--选中SettingItemView条目状态切换
  2. OC-Category
  3. 一点总结-关于debug比赛
  4. mybatis系列-03-入门程序
  5. SQLiteDatabase里面的简单操作数据库的方法
  6. OpenGL ES 三种类型 uniform attribute varying
  7. android 图片浏览器 demo
  8. sass入门学习篇(二)
  9. Mongo查询关键字
  10. 关于layer的坑
  11. meta的用法
  12. docker面试整理
  13. Java 基础 多线程和线程池基础
  14. 探秘小程序(8):scroll-view组件
  15. 百度-淘宝-360搜索引擎搜索API
  16. python中转义符&amp;str格式化
  17. FluentAPI详细用法
  18. java基础篇---新I/O技术(NIO)
  19. CentOS7使用firewalld打开关闭防火墙与端口[转]
  20. attack source code

热门文章

  1. 安装CoreOS到磁盘
  2. shell脚本学习笔记 (流编辑器sed)
  3. 【demo练习三】:图片水平滚动、点击按钮变更图片动画
  4. CPI和GDP有什么关系
  5. 2014年java软件project师面试题收集
  6. C - The C Answer (2nd Edition) - Exercise 1-1
  7. LR中select next row和update value on的设置
  8. sql中decode()重要函数使用
  9. PCA tries to preserve linear structure, MDS tries to preserve global geometry, and t-SNE tries to preserve topology (neighborhood structure)
  10. BZOJ4944: [Noi2017]泳池