K-th Number
Time Limit: 20000MS   Memory Limit: 65536K
Total Submissions: 52651   Accepted: 18091
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your
program must answer a series of questions Q(i, j, k) in the form: "What
would be the k-th number in a[i...j] segment, if this segment was
sorted?"

For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the
question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort
this segment, we get (2, 3, 5, 6), the third number is 5, and therefore
the answer to the question is 5.

Input

The
first line of the input file contains n --- the size of the array, and m
--- the number of questions to answer (1 <= n <= 100 000, 1 <=
m <= 5 000).

The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given.

The following m lines contain question descriptions, each
description consists of three numbers: i, j, and k (1 <= i <= j
<= n, 1 <= k <= j - i + 1) and represents the question Q(i, j,
k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
【分析】第一道划分树,懂了一丝,继续努力。。。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <time.h>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define met(a,b) memset(a,b,sizeof a)
#define pb push_back
#define lson(x) ((x<<1))
#define rson(x) ((x<<1)+1)
using namespace std;
typedef long long ll;
const int N=1e5+50;
const int M=N*N+10;
struct P_Tree {
    int n;
    int tree[20][N];
    int sorted[N];
    int toleft[20][N];
    void init(int len) {
        n=len;
        for(int i=0; i<20; i++)tree[i][0]=toleft[i][0]=0;
        for(int i=1; i<=n; i++) {
            scanf("%d",&sorted[i]);
            tree[0][i]=sorted[i];
        }
        sort(sorted+1,sorted+n+1);
        build(1,n,0);
    }
    void build(int l,int r,int dep) {
        if(l==r)return;
        int mid=(l+r)>>1;
        int same=mid-l+1;
        for(int i=l; i<=r; i++)
            if(tree[dep][i]<sorted[mid])
                same--;
        int lpos=l;
        int rpos=mid+1;
        for(int i=l; i<=r; i++) {
            if(tree[dep][i]<sorted[mid]) { //去左边
                tree[dep+1][lpos++]=tree[dep][i];             } else if(tree[dep][i]==sorted[mid]&&same>0) { //去左边
                tree[dep+1][lpos++]=tree[dep][i];
                same--;
            } else //去右边
                tree[dep+1][rpos++]=tree[dep][i];
            toleft[dep][i]=toleft[dep][l-1]+lpos-l;//从1到i放左边的个数
        }
        build(l,mid,dep+1);//递归建树
        build(mid+1,r,dep+1);
    }
    int query(int L,int R,int l,int r,int dep,int k) {
        if(l==r)return tree[dep][l];
        int mid=(L+R)>>1;
        int cnt=toleft[dep][r]-toleft[dep][l-1];
        if(cnt>=k) {
            //L+查询区间前去左边的数的个数
            int newl=L+toleft[dep][l-1]-toleft[dep][L-1];
            //左端点+查询区间会分入左边的数的个数
            int newr=newl+cnt-1;
            return query(L,mid,newl,newr,dep+1,k);//注意
        } else {
            //r+区间后分入左边的数的个数
            int newr=r+toleft[dep][R]-toleft[dep][r];
            //右端点减去区间分入右边的数的个数
            int newl=newr-(r-l-cnt);
            return query(mid+1,R,newl,newr,dep+1,k-cnt);//注意
        }
    }
}tre;
int main() {
    int n,m;
    int u,v,w;
    while(~scanf("%d%d",&n,&m)) {
        tre.init(n);
        while(m--) {
            scanf("%d%d%d",&u,&v,&w);
            printf("%d\n",tre.query(1,n,u,v,0,w));
        }
    }
    return 0;
}

最新文章

  1. mac搭建测试服务器
  2. IE10 和 Chrome50 对日期 new Date() 支持的区别
  3. Windows 10 安装双系统 CentOS 7
  4. throw与throws的区别
  5. JAVA中精确计算金额BigDecimal
  6. django cycle标签
  7. SP避免Form重复提交的三种方案
  8. cocos2d-x Android 环境搭建问题汇总
  9. C++中类的大小计算方法总结《网络+总结》
  10. C# Dapper 轻量ORM调试对SQLServer
  11. kubernetes 安装备注
  12. 思维导图工具XMind
  13. svn 部署
  14. Codeforces Educational Codeforces Round 44 (Rated for Div. 2) E. Pencils and Boxes
  15. windows from docker 安装部署spring jar包方法
  16. JavaScript ES6格式化字符串方法
  17. OpenCV——创建Mat对象、格式化输出、常用数据结构和函数(point,vector、Scalar、Size、Rect、cvtColor)
  18. 两个Integer比较大小需要注意的误区
  19. Erlang中atom的实现
  20. 014-CallbackServlet代码

热门文章

  1. 一个初学者的辛酸路程-初识Django
  2. python中字符串是特殊的列表
  3. 【转载】Unity3D研究院之共享材质的巧妙用法(sharedMaterial效率问题)
  4. python学习总结---函数使用 and 装饰器
  5. 【转】Unity3D 关于贝赛尔曲线,平滑曲线,平滑路径,动态曲线
  6. atom插件之less-autocompile
  7. Git 提交修改
  8. qemu中是怎么模拟的新的设备
  9. Axios &amp; fetch api &amp; Promise &amp; POST
  10. BZOJ 2438:杀人游戏(tarjan+概率)