1147 Heaps(30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure)

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

题意:
给定层序遍历的树,判断是否为大小堆。

思路:
先将输出转化为一棵树,这样就好做了,就是比较暴力
看看 柳婼 の blog 是怎么做的
题解:

 #include<cstdlib>
 #include<cstdio>
 #include<vector>
 using namespace std;
 struct node {
     int value;
     int left;
     int right;
 };
 bool isMaxHeap(vector<node> nodes, int now) {
     bool isMax = true;
      < nodes.size()) {
         ].value) {
             isMax = false;
         }
         else {
             )) {
                 isMax = false;
             }
         }
     }
      +  < nodes.size()) {
          + ].value) {
             isMax = false;
         }
         else {
              + )) {
                 isMax = false;
             }
         }
     }
     return isMax;
 }
 bool isMinHeap(vector<node> nodes, int now) {
     bool isMin = true;
      < nodes.size()) {
         ].value) {
             isMin = false;
         }
         else {
             )) {
                 isMin = false;
             }
         }
     }
      +  < nodes.size()) {
          + ].value) {
             isMin = false;
         }
         else {
              + )) {
                 isMin = false;
             }
         }
     }
     return isMin;
 }
 void PostOrder(vector<node> nodes, int now) {
      < nodes.size()) {
         PostOrder(nodes, now * );
     }
      +  < nodes.size()) {
         PostOrder(nodes, now *  + );
     }
     //nodes[nodes.size() - 1]这个结点不一定是先输出的。
     printf( ? "\n" : " ");
 }
 int main() {
     int n, m;
     scanf("%d %d", &n, &m);
     ; i < n; i++) {
         vector<node> nodes(m+);
         ; j <= m; j++) {
             scanf("%d", &nodes[j].value);
             nodes[j].left = j * ;
             nodes[j].right = j *  + ;
         }
         )) {
             printf("Max Heap\n");
         }
         )) {
             printf("Min Heap\n");
         }
         else {
             printf("Not Heap\n");
         }
         PostOrder(nodes, );
     }
     ;
 }

最新文章

  1. Ajax跨域:Jsonp原理解析
  2. html5高级
  3. ip地址+进程端口号+路径参数同样实现restful访问
  4. 2015-J. PUMA
  5. UVA 11928 The Busy Dog
  6. php self
  7. 编译LOADCEPC.EXE程序
  8. Linux Top 命令解析 比较详细--转
  9. 结构体的sizeof
  10. GMP大法教你重新做人(从入门到实战)
  11. C# 获取当前屏幕DPI
  12. JavaWeb处理GET、POST时的编码乱码问题
  13. f12 headers 变字典快捷方式
  14. centos7 docker升级到最新稳定版本
  15. 每日一练ACM 2019.0418
  16. OneAPM 获得“2018中国 IT 服务创新奖”,彰显技术创新实力
  17. docker中gitlab-runner配置
  18. SpringBoot初识
  19. python之文件系统操作(os模块)
  20. [na]交换机原理/macof

热门文章

  1. 【简单算法】40.Fizz Buzz
  2. [zhuan]使用uiautomator做UI测试
  3. ipython 安装和更新
  4. hzwer分块九题(暂时持续更新)
  5. 搭建JavaWeb应用开发环境
  6. UVA 11922 Splay tree
  7. iostat和iowait详细解说
  8. shell 25个常用命令
  9. Java——Iterate through a HashMap
  10. CentOS 5.8 安装python 和 yum