Double Queue
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13258   Accepted: 5974

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
K P Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

题目大意:

  有三个操作,1 K P:设置点K的优先级为P;

        2 :输出优先级最高的点,并且删除该点

        3 :输出优先级最低的点,并且删除该点  

        0:退出

  用map处理,插入和查找的复杂度都为log n;

 #include <iostream>
#include <algorithm>
#include <string>
#include <queue>
#include <stdio.h>
#include <map>
#include <string.h>
#include <stdlib.h>
using namespace std;
int main()
{
int T,a,P,K;
map<int,int>ID;
map<int,int>::iterator it;
while(scanf("%d",&a)!=EOF){
switch(a){
case :
scanf("%d%d",&P,&K);
ID[K]=P;break;
case :
if(ID.empty())printf("0\n");
else {
it=ID.end();it--;
printf("%d\n",it->second);
ID.erase(it);
}
break;
case :
if(ID.empty())printf("0\n");
else {
it=ID.begin();
printf("%d\n",it->second);
ID.erase(it);
}
break;
case : return ;
}
} return ;
}

最新文章

  1. GDB 完全教程
  2. XMPP环境搭建
  3. CSS3 里添加自定义字体
  4. springMVC返回json
  5. Dynamic CRM 2013学习笔记(十三)附件上传 / 上传附件
  6. blur效果,模糊效果css
  7. poj2104 线段树 划分树
  8. [JS进阶] 编写可维护性代码 (1)
  9. 李洪强iOS开发之OC[013] -类的创建的练习
  10. xss(跨站脚本攻击),crsf(跨站请求伪造),xssf
  11. Dreamweaver安装jQuery插件jQuery_API.mxp
  12. Keil C51中变量的使用
  13. BZOJ1782: [Usaco2010 Feb]slowdown 慢慢游
  14. SKPhysicsJointSpring类
  15. Node.js之操作文件系统(二)
  16. NOIP 2018 大翻车记
  17. python之路--装饰器
  18. 201621123002《JAVA程序设计》第五周学习总结
  19. BZOJ1202 [HNOI2005]狡猾的商人 spfa
  20. C++学习(十五)(C语言部分)之 数组二

热门文章

  1. Moq的使用心得
  2. CLR 的执行模型(2)
  3. VMware NAT方式 CentOS 6.8配置静态IP
  4. Solr与MongoDB集成,实时增量索引
  5. 网站部署到Windows Azure Website上
  6. storm源码之storm代码结构【译】
  7. mvc+linq+EF对数据表的查删改
  8. C#单例模式的三种写法 以及 继承面试题
  9. jquery mobile Checkbox动态添加刷新及事件绑定
  10. SOCKET网络编程细节问题1