坦克大战

时间限制:1000 ms  |  内存限制:65535 KB
难度:3
描述
Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 




Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you
can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear
(i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?
输入
The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T'
(target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.
输出
For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.
样例输入
3 4
YBEB
EERE
SSTE
0 0
样例输出
8
来源
POJ
上传者

sadsad

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
#define MAXN 310
#define INF 0x3f3f3f3f
int dx[4]={0,0,1,-1};
int dy[4]={1,-1,0,0};
struct node
{
int x,y;
int step;
friend bool operator < (node s1,node s2)
{
return s1.step>s2.step;
}
}p,temp;
int n,m,vis[MAXN][MAXN],sx,sy,ans;
char map[MAXN][MAXN];
bool judge(node s)
{
if(s.x<0||s.x>=n||s.y<0||s.y>=m)
return true;
if(map[s.x][s.y]=='R'||map[s.x][s.y]=='S'||vis[s.x][s.y])
return true;
return false;
}
void bfs()
{
priority_queue<node>q;
memset(vis,0,sizeof(vis));
p.x=sx;
p.y=sy;
p.step=0;
vis[sx][sy]=1;
q.push(p);
while(!q.empty())
{
p=q.top();
q.pop();
if(map[p.x][p.y]=='T')
{
ans=p.step;
return ;
}
for(int i=0;i<4;i++)
{
temp.x=p.x+dx[i];
temp.y=p.y+dy[i];
if(judge(temp))
continue;
if(map[temp.x][temp.y]=='B')
temp.step=p.step+2;
else
temp.step=p.step+1;
vis[temp.x][temp.y]=1;
q.push(temp);
}
}
}
int main()
{
while(scanf("%d%d",&n,&m),m+n)
{
memset(map,'\0',sizeof(map));
for(int i=0;i<n;i++)
{
scanf("%s",map[i]);
for(int j=0;j<m;j++)
{
if(map[i][j]=='Y')
{
sx=i;
sy=j;
}
}
}
ans=INF;
bfs();
if(ans!=INF)
printf("%d\n",ans);
else
printf("-1\n");
}
return 0;
}

最新文章

  1. spring data jpa分页
  2. 利用ajax的方式来提交数据到后台数据库及交互功能
  3. 使SWT/JFace支持跨平台
  4. TranslateAnimation 运行动画后实际位置不正确问题
  5. Orchard源码分析(3):Orchard.WarmupStarter程序集
  6. bzoj4514: [Sdoi2016]数字配对--费用流
  7. 重回博客 谈一谈Node中的异步和单线程
  8. 从MySQL随机选取数据
  9. 调用start()方法和直接调用run()方法的区别
  10. zookeeper注册与发现
  11. 剑指offer(19)二叉树中和为某一值的路径
  12. 生产环境中tomcat的配置
  13. json包
  14. English trip V1 - 9.Do you Ever Say Never? 你有没有说永远不会? Teacher:Lamb Key: Adverbs of frequency (频率副词)
  15. Java 面向对象之构造方法
  16. Codeforces Round #396 (Div. 2) B. Mahmoud and a Triangle 贪心
  17. netbeans 类重复 解决
  18. php 获取唯一字符串与文件扩展名函数
  19. Mac下在Intellij Idea里设置VM运行参数的正确方法
  20. 于C#控制台传递参数和接收参数

热门文章

  1. 前端面试基础-html篇之H5新特性
  2. 控制台输入年龄,根据年龄输出不同的提示 ------if……else if ……else 语句
  3. 【Oracle】删除手工创建的数据库
  4. vue-router 嵌套路由没反应
  5. static关键字的定义与使用
  6. Android 性能测试初探(三)
  7. python 从给定的URL中提取顶级域名(TLD)
  8. 【剑指Offer】48、不用加减乘除做加法
  9. 58.fetch phbase
  10. C#学习笔记_05_输入输出