Going Home

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3125    Accepted Submission(s): 1590

Problem Description
On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters
a house. The task is complicated with the restriction that each house can accommodate only one little man. 



Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates
there is a little man on that point. 



You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.
 
Input
There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both
N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.
 
Output
For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay. 
 
Sample Input
2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0
 
Sample Output
2
10
28
 

题意:把H和m一一配对。他们所需走的最小步数和 为多少。

做法:用bfs 先找出 随意 H 和 m 直接的最小步数。记录下来。 然后像二分图一样建图。 起点到 全部home 流量1,费用0。 home 和man 之间的费用为距离,流量1,man和终点ee之间流量1,费用0。 建图完。然后用最小费用最大流 跑一边就ok了。

#include <cstdio>
#include <iostream>
#include <cmath>
#include <cstring>
#include <vector>
#include <stdlib.h>
#include <queue>
#include <map>
#include <algorithm>
using namespace std; const int MAXN = 10100;
const int MAXM = 30000000;
const int INF = 0x3f3f3f3f;
struct Edge
{
int to,next,cap,flow,cost;
}edge[MAXM];
int head[MAXN],tol;
int pre[MAXN],dis[MAXN];
bool vis[MAXN];
int N;//节点总个数,节点编号从0~N-1
void init(int n)
{
N = n;
tol = 0;
memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int cap,int cost)
{
edge[tol].to = v;
edge[tol].cap = cap;
edge[tol].cost = cost;
edge[tol].flow = 0;
edge[tol].next = head[u];
head[u] = tol++;
edge[tol].to = u;
edge[tol].cap = 0;
edge[tol].cost = -cost;
edge[tol].flow = 0;
edge[tol].next = head[v];
head[v] = tol++;
}
bool spfa(int s,int t)
{
queue<int>q;
for(int i = 0;i < N;i++)
{
dis[i] = INF;
vis[i] = false;
pre[i] = -1;
}
dis[s] = 0;
vis[s] = true;
q.push(s);
while(!q.empty())
{
int u = q.front();
q.pop();
vis[u] = false;
for(int i = head[u]; i != -1;i = edge[i].next)
{
int v = edge[i].to;
if(edge[i].cap > edge[i].flow &&
dis[v] > dis[u] + edge[i].cost )
{
dis[v] = dis[u] + edge[i].cost;
pre[v] = i;
if(!vis[v])
{
vis[v] = true;
q.push(v);
}
}
}
}
if(pre[t] == -1)return false;
else return true;
}
//返回的是最大流。 cost存的是最小费用
int minCostMaxflow(int s,int t,int &cost)
{
int flow = 0;
cost = 0;
while(spfa(s,t))
{
int Min = INF;
for(int i = pre[t];i != -1;i = pre[edge[i^1].to])
{
if(Min > edge[i].cap - edge[i].flow)
Min = edge[i].cap - edge[i].flow;
}
for(int i = pre[t];i != -1;i = pre[edge[i^1].to])
{
edge[i].flow += Min;
edge[i^1].flow -= Min;
cost += edge[i].cost * Min;
}
flow += Min;
}
return flow;
} int n,m;
struct node
{
int x,y,bu;
};
//addedge(int u,int v,int cap,int cost)
char mp[110][110];//地图
char num[110][110];//点查 号
int mp_dis[110][110];//号 号距离 前 home 后 men
int mp_vis[110][110];
int dir[4][2]={1,0,0,1,0,-1,-1,0};
void bfs(int x,int y)
{
memset(mp_vis,-1,sizeof mp_vis);
queue<node> q;
node sta,nw,tem;
sta.bu=0;
sta.x=x;
sta.y=y;
q.push(sta); while(!q.empty())
{
nw=q.front();
q.pop();
if(mp[nw.x][nw.y]=='m')
mp_dis[num[x][y]][num[nw.x][nw.y]]=nw.bu;
for(int i=0;i<4;i++)
{
int xx=nw.x+dir[i][0];
int yy=nw.y+dir[i][1];
if(xx<0||xx>=n||yy<0||yy>=m)
continue;
if(mp_vis[xx][yy]!=-1&&nw.bu+1>=mp_vis[xx][yy])
continue;
tem.x=xx;
tem.y=yy;
mp_vis[xx][yy]=tem.bu=nw.bu+1;
q.push(tem);
}
}
} int main()
{
while(cin>>n>>m,n||m)
{
for(int i=0;i<n;i++)
{
scanf("%s",mp[i]);
}
int home,man;
home=man=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(mp[i][j]=='H')
num[i][j]=home++;
if(mp[i][j]=='m')
num[i][j]=man++;
}
} for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(mp[i][j]=='H')
bfs(i,j); }
}
int ss=home+man;
int ee=home+man+1;
init(home+man+2); for(int i=0;i<home;i++)
{
for(int j=0;j<man;j++)
{
addedge(i,home+j,1,mp_dis[i][j]);
}
} for(int i=0;i<home;i++)
addedge(ss,i,1,0);
for(int i=0;i<man;i++)
addedge(home+i,ee,1,0); /*
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{ printf("%c%d ",mp[i][j],num[i][j]);
}
puts("");
} for(int i=0;i<home;i++)
{
for(int j=0;j<man;j++)
{
printf("%d ",mp_dis[i][j]);
}
puts("");
}
*/
int ans;
minCostMaxflow(ss,ee,ans); printf("%d\n",ans); }
return 0;
} /*
2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0
*/

最新文章

  1. VS2010 AlwaysCreate
  2. adb shell dumpsys package 查看versionCode
  3. 在Eclipse发展Webapp部署过程,缓存的位置
  4. 如何在我自己的web 项目的jsp页面中添加链接,直接让别人通过内网在我的电脑上下载文件
  5. 使用Atom打造无懈可击的Markdown编辑器
  6. Python基础篇(六)
  7. 反向Ajax之Socket.io
  8. [Luogu P1495]曹冲养猪
  9. vim快捷键速查
  10. Linux (Redhat / Fedora / CentOS) 更改 hostname 的方式
  11. LOJ#2353 货币兑换
  12. P、NP、NPC、NPH问题的区别和联系
  13. appium桌面版本以及一些自动化测试方方封装
  14. [Robot Framework] 通过Robot Remote Server调用White Library测试WPF开发的桌面产品
  15. 03-Centos7安装部署Mirrorgate-踩坑记录
  16. HDU 3980 Paint Chain (sg函数)
  17. [leetcode]340. Longest Substring with At Most K Distinct Characters至多包含K种字符的最长子串
  18. 07 Maven 使用Nexus创建私服
  19. Tomcat改端口号;修改访问路径,以及配置Context 标签以后Tomcat启动不了
  20. NIO与Socket

热门文章

  1. 洛谷 P1898 缘分计算
  2. HDU 4462 Scaring the Birds (暴力枚举DFS)
  3. URAL 1614. National Project “Trams” (图论大YY)
  4. bzoj 1010 (单调决策优化)
  5. tomcat安装部署
  6. 配置CiscoWorks 2000 ANI同步
  7. Android使用token维持登陆状态的方法
  8. BZOJ2668: [cqoi2012]交换棋子(费用流)
  9. C#获得文件夹下文件名
  10. Objective-C method及相关方法分析