pid=4970">Killing Monsters

                                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072
K (Java/Others)

Problem Description
Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.



The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R.
Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in
block 2 and the last in block 3.



A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.



Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.

Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.
 
Input
The input contains multiple test cases.



The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0
< Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi
<= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.



The input is terminated by N = 0.
 
Output
Output one line containing the number of surviving monsters.
 
Sample Input
5
2
1 3 1
5 5 2
5
1 3
3 1
5 2
7 3
9 1
0
 
Sample Output
3
Hint
In the sample, three monsters with origin HP 5, 7 and 9 will survive.
 
题意:有n座塔,每座塔的攻击范围为[l,r],攻击力为d,有k个怪兽从这些塔前面经过。第i仅仅怪兽初始的生命力为hp,出现的位置为x。终点为第n个格子。问最后有多少仅仅怪兽还活着。
一開始用线段树写的,果断超时了。
事实上仅仅需开一个大小为n的数组attack。初值为0,对于每座塔的攻击(l,r,d),将attack[l]的值加上d,attack[r+1]的值减去d,然后对attack数组从前往后扫一遍。就可以求出经过每一个格子时受到的伤害;在从后往前扫一遍,便可求出从每一个格子到第n个格子受到的总伤害。最后对于每仅仅怪兽仅仅需推断attack[x]和hp的大小就可以。
#include<cstdio>
#include<cstring>
const int N = 100005;
typedef __int64 LL;
LL attack[N];
int main()
{
int n, l, r, m, k, pos;
LL d, hp;
while(~scanf("%d",&n) && n) {
memset(attack, 0, sizeof(attack));
scanf("%d",&m);
while(m--) {
scanf("%d%d%I64d", &l, &r, &d);
attack[l] += d;
attack[r+1] -= d;
}
for(int i = 2; i <= n; i++)
attack[i] += attack[i-1];
for(int i = n - 1; i > 0; i--)
attack[i] += attack[i+1];
int ans = 0;
scanf("%d",&k);
while(k--) {
scanf("%I64d%d",&hp, &pos);
if(attack[pos] < hp)
ans++;
}
printf("%d\n", ans);
}
return 0;
}


最新文章

  1. python 文件编码
  2. C Primer Plus(第五版)10
  3. tcp timestamp
  4. TForm的显示过程
  5. Maven常用插件参数
  6. 【Google Protocol Buffer】Google Protocol Buffer
  7. Action类一般情况为何要继承ActionSupport
  8. CSS与JS中的相对路径引用
  9. 使用js动态添加组件
  10. sql中1=1的and和or问题
  11. 【土旦】在vue filters中 优雅的使用对象的key、value来替换 if switch多重判断简化流程
  12. 米卡 Mica Logo 存放处
  13. CAP理论和Base理论
  14. CSS实现背景透明,文字不透明(兼容所有浏览器)
  15. java程序中默认整形值常量是什么类型的?如何区分不同类型的整型数值常量?
  16. 高效办公必不可少的5个Excel技巧
  17. makefile——小试牛刀
  18. swift - VC添加手势返回
  19. 百度地图插件(百度地图AK申请配置指南)
  20. Office 2010激活 NO KMS products detected问题

热门文章

  1. CF633H Fibonacci-ish II
  2. MySQL字符集设定与查询
  3. 基于flask的网页聊天室(二)
  4. css选择器(2)——属性选择器和基于元素结构关系的选择器
  5. winfor应用程序打印报表清单
  6. 大数据学习——linux常用命令(二)
  7. sql语句中嵌套2层循环
  8. Leetcode 289.生命游戏
  9. 导师高茂源:用CODEX创新方法破解西方创新“秘密”(转)
  10. Access数据库密码破解 C#