Halloween treats
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6631   Accepted: 2448   Special Judge

Description

Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts,
the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number
of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.

Your job is to help the children and present a solution.

Input

The input contains several test cases.

The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space
separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit
neighbour i.

The last test case is followed by two zeros.

Output

For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets).
If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.

Sample Input

4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0

Sample Output

3 5
2 3 4

Source

题意:给出c和n,接下来n个数,求随意的几个数的和为c的倍数,输出随意一组答案(注意是随意的)

抽屉原理: 放10个苹果到九个抽屉,最少有一个抽屉有大于1的苹果

这个题为什么说是抽屉原理呢?  你计算前n个数(一共同拥有n个和)的和mod  c ,由于n大于c,所以你推測会有多少个余数。

最多有 n个。即 0~n-1,而0是满足条件的,换而言之。这n个余数中要么有0,要么最少有两个同样的余数,

如今看两个余数同样的情况,比如   如果sum[1]%c==sum[n]%c  那么a[2]+a[3]+..+a[n]就是 c  的倍数。就说这么多了。

看代码吧:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 100005 int a[N];
int vis[N];
int c,n; int main()
{
int i;
while(~scanf("%d%d",&c,&n))
{
memset(vis,-1,sizeof(vis)); for(i=1;i<=n;i++)
{
scanf("%d",&a[i]);
} int temp=0,j; for(i=1;i<=n;i++)
{
temp+=a[i];
temp%=c; if(temp==0)
{
for(j=1;j<=i;j++)
if(j==1)
printf("%d",j);
else
printf(" %d",j); printf("\n");
break;
} if(vis[temp]!=-1)
{ for(j=vis[temp]+1;j<=i;j++)
if(i==j)
printf("%d",j);
else
printf("%d ",j); printf("\n"); break;
} vis[temp]=i;
} }
return 0;
}

最新文章

  1. QTableWidget行选中/删除/添加行
  2. C# out ref 重载
  3. GitHub的三个按钮
  4. JavaScript引用类型
  5. C/C++指针内存分配小细节
  6. C++类的运用 和 三大函数
  7. SparkSQL On Yarn with Hive,操作和访问Hive表
  8. SVN安装与使用
  9. 向量相加CUDA练习
  10. Android高效内存1:一张图片占用多少内存
  11. mongoDB创建数据库用户
  12. 计时器C#
  13. GCD Again
  14. [Swift]LeetCode509. 斐波那契数 | Fibonacci Number
  15. git操作+一个本地项目推到github上+注意
  16. .net 本地日志的添加
  17. HDU 5977 Garden of Eden(点分治求点对路径颜色数为K)
  18. Linux打开TCP BBR拥塞控制算法
  19. [Proposal]Transform ur shapes!
  20. 【BZOJ1081】[SCOI2005]超级格雷码(搜索)

热门文章

  1. jQuery 全选、全不选、反选
  2. iView webapp / Mint UI / MUI [前端UI]
  3. QTreeWidgetItem和QTreeWidgetItemIterator
  4. webstorm 设置ES6语法支持以及添加vuejs开发配置
  5. Maven常用仓库地址以及手动添加jar包到仓库
  6. MyEclipse2017修改Web Context Root
  7. 第2节 hive基本操作:9、hive当中创建外部表的语法及外部表的操作&amp;分区表的语法和操作
  8. python note of decorator
  9. 两种js下载文件的方法(转)
  10. [Python3网络爬虫开发实战] 1.9.3-Scrapyd-Client的安装