Watch The Movie

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

Total Submission(s): 7811    Accepted Submission(s): 2496

Problem Description

New semester is coming, and DuoDuo has to go to school tomorrow. She decides to have fun tonight and will be very busy after tonight. She like watch cartoon very much. So she wants her uncle to buy some
movies and watch with her tonight. Her grandfather gave them L minutes to watch the cartoon. After that they have to go to sleep.

DuoDuo list N piece of movies from 1 to N. All of them are her favorite, and she wants her uncle buy for her. She give a value Vi (Vi > 0) of the N piece of movies. The higher value a movie gets shows that DuoDuo likes it more. Each movie has a time Ti to play
over. If a movie DuoDuo choice to watch she won’t stop until it goes to end.

But there is a strange problem, the shop just sell M piece of movies (not less or more then), It is difficult for her uncle to make the decision. How to select M piece of movies from N piece of DVDs that DuoDuo want to get the highest value and the time they
cost not more then L.

How clever you are! Please help DuoDuo’s uncle.
 

Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by input data for each test case:

The first line is: N(N <= 100),M(M<=N),L(L <= 1000)

N: the number of DVD that DuoDuo want buy. 

M: the number of DVD that the shop can sale.

L: the longest time that her grandfather allowed to watch.

The second line to N+1 line, each line contain two numbers. The first number is the time of the ith DVD, and the second number is the value of ith DVD that DuoDuo rated.
 

Output
Contain one number. (It is less then 2^31.)

The total value that DuoDuo can get tonight.

If DuoDuo can’t watch all of the movies that her uncle had bought for her, please output 0.
 

Sample Input

1
3 2 10
11 100
1 2
9 1
 

Sample Output

3
 

解题心得:

1、这个题感觉真的好多坑,虽然知道是二维费用的背包问题但是还是错的很悲伤。先来数数这个题的坑。第一,首先被英语给坑了一把,题目要求是恰好m个片的时候不超过时间L的最大的价值,第二,这个题的价值可能是负数,所以在dp初始化的时候不能初始化为零,第三这个题只能使用二维数组,不能使用结构体来模拟,当时在想这个题的时候没用使用二维数组来做,用的结构体,但是很惨。后来找到了BUG,就不多说了,说说二维数组。

2、二维数组dp[i][j],i表示当前有I张片子,使用了j的时间的最高的价值。可以看成一个0-1背包问题,里面的内层循环用二维数组,改成一个两层循环,思维还是没怎么变,只是实现方法变了一下。

#include<bits/stdc++.h>
using namespace std;
const int maxn1 = 105;
const int maxn2 = 1010;
const int Min = -0x7f7f7f7f;
int dp[maxn1][maxn2];
struct Res
{
int va;
int time;
}res[maxn1];
int main()
{
int n,m,l;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d%d",&n,&m,&l);
for(int i=1;i<=n;i++)
scanf("%d%d",&res[i].time,&res[i].va);
for(int i=0;i<=m;i++)
for(int j=0;j<=l;j++)
dp[i][j] = Min;
for(int i=0;i<=l;i++)
dp[0][i] = 0;
for(int i=1;i<=n;i++)
for(int j=m;j>=1;j--)//可以把以下的二维循环看成0-1背包问题的内层循环
for(int k=l;k>=res[i].time;k--)
dp[j][k] = max(dp[j][k],dp[j-1][k-res[i].time]+res[i].va); if(dp[m][l] < 0)
printf("0\n");
else
printf("%d\n",dp[m][l]);
}
}

最新文章

  1. 在mongoose中使用$match对id失效的解决方法
  2. 【集合框架】JDK1.8源码分析之ArrayList(六)
  3. 无线OSS-高精度整数加法
  4. js之oop &lt;二&gt; 对象属性
  5. 受限玻尔兹曼机(RBM)学习笔记(五)梯度计算公式
  6. OpenStack 的windows镜像的开启办法
  7. Message,MessageQueue,Looper,Handler详解+实例
  8. Linux文件系统的几个性能测试软件小结
  9. 了不起的分支和循环03 - 零基础入门学习Python009
  10. 【转载】python 模块 - random生成随机数模块
  11. 报表学习总结(一)——ASP.NET 水晶报表(Crystal Reports)的简单使用
  12. 分享我的学习记录 svn地址
  13. Java第二章----对象和类
  14. JavaScript发布/订阅实例
  15. Web高级 网站安全
  16. JQuery框架2.位置属性|筛选方法|事件
  17. 005.HAProxy+Keepalived高可用负载均衡
  18. Java基础知识(JAVA集合框架之List与Set)
  19. js改变表单的内容样式
  20. [luogu 2458][SDOI2006]保安站岗

热门文章

  1. 《C#高效编程》读书笔记11-理解短小方法的优势
  2. java反射-使用反射获取类的所有信息
  3. springboot 学习笔记(五)
  4. agc016C - +/- Rectangle(构造 智商题)
  5. jQuery的parent和parents和closest区别
  6. Android ImageView的几种对图片的缩放处理 解决imageview放大图片后失真问题解决办法
  7. Jquery里面的$(this)和this, 有什么区别
  8. spring 中使用quartz实现定时任务
  9. VMware-Ubuntu16.04LTS-安装ssh
  10. vue系列(一)子组件和父组件