解题心得:

1、注意审题,此题是在规定的时间达到规定的地点,不能早到也不能晚到。并不是最简单的dfs

2、在规定时间达到规定的地点有几个剪枝:

一、公式:所需的步骤 - x相差行 - y相差列 = 偶数。(这个解释很简单,无论怎么走,都可以把走的总路程分解到x方向和y方向,哪怕反向走,走回来后的步骤+反向走的步骤也一定是偶数,假设运用正交分解走到了终点(上面公式),但是步骤没走够,可以以最终的目标点为起点任选两格来回走消耗步骤,但是减去正交分解的步数后若是奇数,那么在终点来回走将步数消耗完之后必然会走出去而不能停留在终点。)

二、总的格数减去墙数一定大于等于所需的步骤

三、当时间超出了所需的时间时要return,并且消除标记。

题目:

Tempter of the Bone

Time Limit :1s

Memory limit :32M

Accepted Submit :305

Total Submit :1026

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;

‘S’: the start point of the doggie;

‘D’: the Door; or

‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.

Output

For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.

Sample Input

4 4 5

S.X.

..X.

..XD

….

3 4 5

S.X.

..X.

S

…D

0 0 0

Sample Output

NO

YES

#include<stdio.h>
#include<cstring>
#include<iostream>
using namespace std;
char maps[10][10];
int n,m,t,cnt//记录步骤;
int use[10][10],dir[4][2]={0,1,0,-1,1,0,-1,0};
bool flag//标记是否在规定的时间点找到目标;
struct node
{
int x,y;
}aim,now;//记录出口和启动点
int abs(int num)
{
if(num < 0)
return 0-num;
else
return num;
}
void dfs(int x,int y,int cnt)
{
int i,temp;
if(x == aim.x && y == aim.y && t == cnt)
{
flag = true;
printf("YES\n");
return;
}
temp = abs(t-cnt) - (aim.x - x) - (aim.y - y);//这很重要,一定要注意,在时间超出之后要return,。。。。哎!
if(temp<0 || temp%2)
return;
if(x<0 || y<0 || x>=n || y>=m)
return;
for(i=0;i<4;i++)
{ if(use[x+dir[i][0]][y+dir[i][1]] != 1 && maps[x+dir[i][0]][y+dir[i][1]] != 'X')
{
use[x+dir[i][0]][y+dir[i][1]] = 1;
dfs(x+dir[i][0],y+dir[i][1],cnt+1);
if(flag)
return;
use[x+dir[i][0]][y+dir[i][1]] = 0;
}
}
return;
}
int main()
{
while(scanf("%d%d%d",&n,&m,&t)!=EOF)
{
int d = 0;;
if(n == 0 && m == 0 && t == 0)
break;
cnt = 0;
memset(use,0,sizeof(use));
for(int i=0;i<n;i++)
scanf("%s",maps[i]);
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(maps[i][j] == 'D')
{
aim.x = i;
aim.y = j;
}
if(maps[i][j] == 'S')
{
now.x = i;
now.y = j;
}
if(maps[i][j] == 'X')
d++;
}
}
if(m*n - d < t)
{
printf("NO\n");
continue;
}
flag = false;
use[now.x][now.y] = 1;
dfs(now.x,now.y,cnt);
if(!flag)
printf("NO\n");
}
}

最新文章

  1. 后台接收前台传入的json 数据
  2. 【转】HTTP长连接与短连接
  3. 使用maven 命令运行项目
  4. 关于js闭包杂记
  5. Apache经常使用配置
  6. Python set() 函数
  7. Redis在Linux中安装使用
  8. List删除
  9. 新浪某站CRLF Injection导致的安全问题
  10. 解决 docker 报错: Error starting daemon: error initializing graphdriver: backing file system is unsupported for this graph driver
  11. MySQL(十二)游标和触发器
  12. 工具使用-----Jmeter教程 简单的压力测试
  13. Python--异常处理和断言
  14. layer常用方法代码
  15. ccc数据库的水平分割和垂直分割
  16. shiro缓存
  17. 使用cmd命令打开文件夹
  18. echarts y轴,显示数据,但不显示竖线
  19. DVD项目
  20. spring4-2-bean配置-6-使用外部属性文件

热门文章

  1. Cucumber 步骤中传Data Table作为参数
  2. hibernate课程 初探单表映射2-3 session简介
  3. 前端seo基础规范
  4. Sublime Text3安装SublimeGit插件
  5. FusionCharts可使用JavaScript渲染iPhone/iPod/iPad图表
  6. Eucalyptus镜像管理
  7. GitLab关于SSH的使用
  8. codeblocks winsock配置
  9. Redis安装配置及在Python上的应用
  10. this.value = this.placeholder || this.getAttribute(&#39;placeholder&#39;)