题意:

某公司要举办一次晚会,但是为了使得晚会的气氛更加活跃,每个参加晚会的人都不希望在晚会中见到他的直接上司,现在已知每个人的活跃指数和上司关系(当然不可能存在环),求邀请哪些人(多少人)来能使得晚会的总活跃指数最大。

解题思路:

任何一个点的取舍可以看作一种决策,那么状态就是在某个点取的时候或者不取的时候,以他为根的子树能有的最大活跃总值。分别可以用f[i,1]和f[i,0]表示第i个人来和不来。

当i来的时候,dp[i][1] += dp[j][0];//j为i的下属

当i不来的时候,dp[i][0] +=max(dp[j][1],dp[j][0]);//j为i的下属

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output

Output should contain the maximal sum of guests’ ratings.

Sample Input

7

1

1

1

1

1

1

1

1 3

2 3

6 4

7 4

4 5

3 5

0 0

Sample Output

5

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std; typedef long long ll;
const int maxn=6005;
const int INF=0x3f3f3f3f; //先建树,找到根节点,然后开始dfs
int n,m,x,y;
int dp[maxn][2],vis[maxn],father[maxn];//dp[i][1]表示来,dp[i][0]表示不来 void dfs(int node)
{
int i,j;
vis[node]=1;
for(i=1; i<=n; i++)
{
if(!vis[i]&&father[i]==node)
{
dfs(i);//从根节点的儿子节点开始递归
dp[node][1]+=dp[i][0];//上司来
dp[node][0]+=max(dp[i][1],dp[i][0]);//上司不来,然后看下属来还是不来
}
}
} int main()
{
while(~scanf("%d",&n))
{
int i,j;
memset(father,0,sizeof(father));
memset(dp,0,sizeof(dp));
memset(vis,0,sizeof(vis));
for(i=1; i<=n; i++)
scanf("%d",&dp[i][1]);
int root=0;
//bool flag=1;
while(~scanf("%d %d",&x,&y)&&(x!=0||y!=0))
{
father[x]=y;
//if(root==x||flag)
//root=y;
}
root=y;
while(father[root])
root=father[root];//找根节点
dfs(root);
int maxx=max(dp[root][1],dp[root][0]);
printf("%d\n",maxx);
}
return 0;
}

//更快的一种方法
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL数值算法头文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板类头文件
using namespace std; //typedef long long ll;
//const int maxn=6005;
//const int INF=0x3f3f3f3f; struct node
{
int child,father,brother,present,not_present;
int max()//结构体内的函数调用时耗时少
{
return present>not_present?present:not_present;
}
void init()
{
child=father=brother=not_present=0;
}
} tree[6005]; void dfs(int root)
{
int son = tree[root].child;
while(son)
{
dfs(son);
tree[root].present+=tree[son].not_present;
tree[root].not_present+=tree[son].max();
son = tree[son].brother;
}
} int main()
{
int n,i,j,k,l;
while(~scanf("%d",&n)&&n)
{
for(i = 1; i<=n; i++)
{
scanf("%d",&tree[i].present);
tree[i].init();
}
while(~scanf("%d%d",&l,&k),l+k)
{
tree[l].father = k;
tree[l].brother = tree[k].child;
tree[k].child = l;
}
for(i = 1; i<=n; i++)
{
if(!tree[i].father)
{
dfs(i);
printf("%d\n",tree[i].max());
break;
}
}
} return 0;
}

最新文章

  1. C语言、结构体 定义
  2. 1-学习前言&amp;C语言概述
  3. Android项目架构之业务组件化
  4. 【LINUX命令】之MV
  5. SqlServer2008 无法修改表,超时时间已到 在操作完成之前超时解决方法
  6. C#集合u
  7. win7 64系统安装oracle客户端使用PL/SQL Developer工具
  8. mongodb子文档查询
  9. hdu 1686 Oulipo KMP匹配次数统计
  10. 1045: [HAOI2008] 糖果传递 - BZOJ
  11. String类 and StringBuffer类
  12. VC实现将对话框最小化到系统托盘
  13. COM编程-注册DLL形式的COM服务器
  14. EJB系列 - 消息与MDB
  15. 【Python】Part1 应用1-Netcat
  16. Context连接和断开的情况下的CRUD操作
  17. js:捕获冒泡和事件委托
  18. 用JS制作一个信息管理平台(1)
  19. 支撑大规模公有云的Kubernetes改进与优化 (3)
  20. ms17010漏洞复现-2003

热门文章

  1. Git 常见工作流
  2. free命令buff和cache的区别
  3. 20、redis和memcached比较?
  4. 父元素与子元素之间的margin-top问题(css hack)
  5. Edgware Feign hystrix-dashboard
  6. 2018DDCTF Misc部分WP
  7. Laravel 5.2 数据库迁移和数据填充
  8. 測試 battery capacity curve 的負載
  9. WoW[www]
  10. form 表单获取所有数据 封装方法