Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38918   Accepted: 15751

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 

The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines
of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

简单的最小生成树问题。

。题意要你求得最短的距离。

。1A水过


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath> using namespace std;
const int INF = 0x3f3f3f3f;
int map[105][105];//地图
int lowlen[105];//最短距离
int vist[105];//prim中用于看节点是否进树
int ans;
int n; void init()
{
for(int i=1; i<=n; i++)
for(int j=1; j<=n; j++)
scanf("%d", &map[i][j]);
memset(vist, 0, sizeof(vist));
memset(lowlen, 0, sizeof(lowlen));
} void prim()//prim算法
{
int temp;
ans = 0;
for(int i=1; i<=n; i++)
lowlen[i] = map[1][i];
vist[1] = -1;
for(int i=2; i<=n; i++)
{
temp = INF;
int k =0;
for(int j=1; j<=n; j++)
{
if( vist[j]!=-1 && temp>lowlen[j] )
{
temp = lowlen[j];
k = j;
}
}
vist[k] = -1;
ans += temp;
for(int j=1; j<=n; j++)
{
if(vist[j]!=-1 && lowlen[j]>map[k][j])
{
lowlen[j] = map[k][j];
}
}
}
printf("%d\n", ans);
} int main()
{
while(scanf("%d", &n)==1)
{
init();
prim();
} return 0;
}

最新文章

  1. 深入理解JavaScript——闭包
  2. WebView的使用
  3. EntityFramework Core 封装
  4. .net RPC框架选型
  5. Github GUI 托管代码教程
  6. Innodb之监控Buffer pool Load progress
  7. C++ —— 类的基础
  8. BST 二叉搜索树
  9. Collection和Map的默认扩容参数
  10. ubuntu 修改网卡名称 更改设备网卡名称 修改eno16777736为eth0 ubuntu 15.10网卡名称为eno16777736
  11. MySQL导入数据报 Got a packet bigger than‘max_allowed_packet’bytes 错误的解决方法
  12. Windows10系统网络连接问题
  13. BizTalk RosettaNet解决方案之Loopback
  14. web(六)css的基本语法、取值与单位
  15. mysql数据库优化(四)-项目实战
  16. MySQL 忘记root密码的两种处理方法
  17. 【jquery】基于 jquery 的翻牌效果 flip
  18. 利用VisualStudio单元测试框架举一个简单的单元测试例子
  19. windows7中的“mklink命令”
  20. August 21st 2017 Week 34th Monday

热门文章

  1. C# mvc Request 请求过长报404错误的解决思路分析
  2. 虚拟PDF打印机
  3. (转)c#中判断是不是数字和字母
  4. ARM的存储器映射与存储器重映射
  5. simple_strtoul()
  6. 乐观锁悲观锁对应的JAVA代码和数据库
  7. MySql_安装及简单命令
  8. LookupError: unknown encoding: cp65001
  9. OpenCV图像金字塔
  10. YARN Application执行流程