Problem Description

There are many secret openings in the floor which are covered by a big heavy stone. When the stone is lifted up, a special mechanism detects this and activates poisoned arrows that are shot near the opening. The only possibility is to lift the stone very slowly and carefully. The ACM team must connect a rope to the stone and then lift it using a pulley. Moreover, the stone must be lifted all at once; no side can rise before another. So it is very important to find the centre of gravity and connect the rope exactly to that point. The stone has a polygonal shape and its height is the same throughout the whole polygonal area. Your task is to find the centre of gravity for the given polygon.

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer N (3 <= N <= 1000000) indicating the number of points that form the polygon. This is followed by N lines, each containing two integers Xi and Yi (|Xi|, |Yi| <= 20000). These numbers are the coordinates of the i-th point. When we connect the points in the given order, we get a polygon. You may assume that the edges never touch each other (except the neighboring ones) and that they never cross. The area of the polygon is never zero, i.e. it cannot collapse into a single line.

Output

Print exactly one line for each test case. The line should contain exactly two numbers separated by one space. These numbers are the coordinates of the centre of gravity. Round the coordinates to the nearest number with exactly two digits after the decimal point (0.005 rounds up to 0.01). Note that the centre of gravity may be outside the polygon, if its shape is not convex. If there is such a case in the input data, print the centre anyway.

Sample Input

2
4
5 0
0 5
-5 0
0 -5
4
1 1
11 1
11 11
1 11

Sample Output

0.00 0.00
6.00 6.00

Source

Central Europe 1999

Recommend

Eddy

求多边形重心的模版题, 

将多边形分为多个三角形,如下图:
 

而多变形的重心根据下式推导出来:

其中,(Xgi,Ygi)为第i个三角形的重心,Si 为第i个三角形的面积,Sall 为凸多边形的总面积,而(Xg,Yg)为多边形的重心

代码如下:

/*
题目输出要求有一句exactly two digits after the decimal point (0.005 rounds up to 0.01)。
而直接使用%.2f是会有带来误差的,因为其自带的是“伪四舍五入”,也就是说: 2.54 -> 2.5
2.55 -> 2.5
2.56 -> 2.6 即当题目要求保留2位小数且四舍五入时,应将自己的结果加上0.001,保证当结果为2.555时能进位。
*/
#include<iostream>
#include<cstdio>
#include<map>
using namespace std;
const int MAXN=1000100;
struct node
{
int x,y;
}a[MAXN];
double _X(node &p1,node &p2,node &p3)
{
return (p2.x-p1.x)*(p3.y-p1.y)-(p3.x-p1.x)*(p2.y-p1.y);
}
pair<double,double> zhongxin(node &p1,node &p2,node &p3)
{
pair<double,double> tmp;
tmp.first=(p1.x+p2.x+p3.x)/3.0;
tmp.second=(p1.y+p2.y+p3.y)/3.0;
return tmp;
}
int main()
{
//freopen("data.in","r",stdin);
int t;
cin>>t;
while(t--){
int n;
cin>>n;
for(int i=0;i<n;i++){
cin>>a[i].x>>a[i].y;
}
double Sall=0,xg=0,yg=0;
pair<double,double> tmp;
double m=0;
for(int i=1;i<n-1;i++){
tmp=zhongxin(a[0],a[i],a[i+1]);
m=_X(a[0],a[i],a[i+1]);
Sall+=m;
tmp.first*=m;
tmp.second*=m;
xg+=tmp.first;
yg+=tmp.second;
}
printf("%.2lf %.2lf\n",xg/Sall+0.001,yg/Sall+0.001);
}
}

最新文章

  1. 我所理解的RESTful Web API [设计篇]
  2. filezilla sftp 文件和linux 文件不同步的问题
  3. VSS 访问问题
  4. 转: CSS中float和clear的理解
  5. VS2008 调试记录
  6. Myeclipse自动生成javabean的get和set方法
  7. Android 自定义控件玩转字体变色 打造炫酷ViewPager指示器
  8. JQuery DataTables Editor---页面内容修改&amp;&amp;数据库信息修改 (1)
  9. 大数据系列之Flume--几种不同的Sources
  10. 【Android Developers Training】 78. 序言:执行网络操作
  11. centos下安装并配置tomcat
  12. Ocelot中文文档-管理
  13. sublimeText3编辑器 + 入门教程 + 使用大全
  14. poj 2420
  15. java中基本类型double和对象类型Double
  16. JavaScript 序列化、转义
  17. 20165213&amp;20165225结对学习感想及创意照
  18. UART串口通信
  19. Bezier曲线
  20. axis client error Bad envelope tag: definitions

热门文章

  1. Process Monitor V2.96 (系统监视工具) 汉化免费绿色版
  2. asp.net MVC Session锁的问题
  3. MySQL字段联合去重sql
  4. Python笔记5(字符串)-20160921
  5. 如何在IIS8.5上面部署php
  6. apue学习记录——配置apue.3e,实现P4‘ls例子
  7. Spring MVC(一)
  8. python获取
  9. mysql简单建表
  10. Windows上安装MongoDB步骤