Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 49436    Accepted Submission(s): 22871

Problem Description

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N 

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each case, print the maximum according to rules, and one line one case.

Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3

题意

求上升子序列的和的最大值,注意对dp数组的初始化

AC代码

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <string>
#define ll long long
#define ms(a) memset(a,0,sizeof(a))
#define pi acos(-1.0)
#define INF 0x3f3f3f3f
const double E=exp(1);
const int maxn=1e6+10;
using namespace std;
int a[maxn];
int b[maxn];
int dp[maxn];
int main(int argc, char const *argv[])
{
int n;
while(~scanf("%d",&n)&&n)
{
ms(a);
ms(dp);
for(int i=0;i<n;i++)
{
cin>>a[i];
// 对dp进行初始化
dp[i]=a[i];
}
int ans=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<i;j++)
{
// 如果是递增的
if(a[i]>a[j])
// 加起来和原本的作比较
dp[i]=max(dp[j]+a[i],dp[i]);
}
// 如果一开始不对dp初始化,要加上下面这一句
// dp[i]=max(dp[i],a[i]);
ans=max(ans,dp[i]);
}
cout<<ans<<endl;
}
return 0;
}

最新文章

  1. git命令查看远程分支
  2. Codeforces Round #389 (Div. 2, Rated, Based on Technocup 2017 - Elimination Round 3) D. Santa Claus and a Palindrome STL
  3. GitLab在Centos下的安装步骤
  4. 使用 python 发送邮件
  5. BIEE 维表
  6. Linux下LDAPSearch的例子
  7. HDU 4888 (网络流)
  8. nginx的upstream目前支持5种方式的分配(转)
  9. git免登录-ssh-key
  10. php透明合并png与jpg图片
  11. XSS测试用例与原理讲解
  12. 学习Oracle应该准备的技能
  13. 网上搜集的一段php可逆加密函数
  14. Java并发编程:同步锁、读写锁
  15. shiro自定义Realm
  16. HDFS的上传与下载(put &amp; get)
  17. 《AlwaysRun!》第一次作业:团队亮相
  18. 二十八、Linux 进程与信号---前台进程组
  19. 线段树及Lazy-Tag
  20. leecode第一百六十九题(求众数)

热门文章

  1. Android 之常用布局
  2. Android--Android Studio 打开ADM报错
  3. Spring注入,Ioc的具体配置
  4. 每天CSS学习之transform-origin
  5. 每天CSS学习之box-shadow
  6. 进程中的Manager(),实现多进程的数据共享与传递
  7. 如何从零安装Mysql
  8. 重载的方式写Python的get请求
  9. JAVA 中的MessageDigest类和Mac类的使用
  10. 关于js中函数的调用问题