1108 Finding Average (20 分)

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where Kis the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output 1:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input 2:

2
aaa -9999

Sample Output 2:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

分析:使用sscanf()和sprintf()函数即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<string>
#include<unordered_map>
#include<set>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
int main(){
#ifdef ONLINE_JUDGE
#else
freopen("input.txt", "r", stdin);
#endif // ONLINE_JUDGE
int n = 0;
scanf("%d", &n);
int cnt = 0;
double sum = 0, num;
for(int i = 0; i < n; ++i){
char str[100], t[100];
scanf("%s", str);
sscanf(str, "%lf", &num);
sprintf(t, "%.2f", num);
bool flag = true;
//写入失败时,写入的地方存的还是之前的内容,所以要比较
for(int i = 0; i < strlen(str); ++i){
if(str[i] != t[i])flag = false;
}
if(flag == false || abs(num) > 1000){
printf("ERROR: %s is not a legal number\n", str);
}else{
cnt++;
sum += num;
}
}
if(cnt == 0){
printf("The average of 0 numbers is Undefined\n");
}else if(cnt == 1){
printf("The average of 1 number is %.2lf\n", sum);
}else{
printf("The average of %d numbers is %.2lf\n", cnt, sum / cnt);
}
return 0;
}

最新文章

  1. Python全栈开发【模块】
  2. LDA(文档主题模型)
  3. 01 Apache Solr:提升检索体验 为什么是Solr
  4. select值的获取及修改
  5. vim黏贴代码格式混乱的解决方法
  6. Kafka实战系列--Kafka API使用体验
  7. FROM_UNIXTIME 格式化MYSQL时间戳函数
  8. Linux命令(14)文件和文件夹权限管理:chmod
  9. HDU 5294 Tricks Device (最短路,最大流)
  10. LAMP php5.4编译 _php_image_stream_putc等问题
  11. 小程序蓝牙BLE——自动连接设备(手环)
  12. java课程设计团队博客《基于学院的搜索引擎》
  13. [matlab] 4.M函数
  14. Paint the Wall ZOJ - 2747
  15. 当php邂逅windows通用上传缺陷
  16. tp5 Excel导出
  17. windows7(64位) PHP APACHE MYSQL
  18. date 修改系统时间
  19. [BZOJ4552][TJOI2016&amp;&amp;HEOI2016]排序(二分答案+线段树/线段树分裂与合并)
  20. show_space

热门文章

  1. CF812A Sagheer and Crossroads 题解
  2. LuoguB2075 幂的末尾 题解
  3. CF106A Card Game 题解
  4. 启动jetty命令
  5. C++ NFS挂载
  6. table中tr、td标签设置只读,不能修改(readonly属性)
  7. 使用.NET 6开发TodoList应用(7)——使用AutoMapper实现GET请求
  8. 小小明系列故事——游戏的烦恼(hdu 4517)
  9. 问题--ImportError: DLL load failed: 找不到指定的模块
  10. Dubbo 的设计思想