1095 Cars on Campus (30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤104), the number of records, and K (≤8×104) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascendingorder of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

注意点:超时问题的处理

  1. 字符串用char[]存储;
  2. 找最值包含在数据处理的过程中
  3. 查找时先排序
#include<iostream>
#include<cstdio>
#include<vector>
#include<string>
#include<unordered_map>
#include<set>
#include<queue>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cctype>
#include<limits>
using namespace std;
struct node{
char id[10];
int t, tag;
bool operator < (const node &a)const{
if(strcmp(id, a.id) == 0)return t < a.t;
else return strcmp(id, a.id) < 0 ? true : false;
}
};
struct car{
char id[10];
int in, out;
bool operator < (const car &a)const{
return in < a.in;
}
};
int main(){
#ifdef ONLINE_JUDGE
#else
freopen("input.txt", "r", stdin);
#endif // ONLINE_JUDGE
int n, m;
scanf("%d %d", &n, &m);
vector<node>v(n);
for(int i = 0; i < n; ++i){
char str[10];
int hh, mm, ss;
scanf("%s %d:%d:%d %s", v[i].id, &hh, &mm, &ss, str);
v[i].t = hh * 3600 + mm * 60 + ss;
v[i].tag = (strcmp(str, "in") == 0) ? 0 : 1;
}
sort(v.begin(), v.end());
vector<car>ans;
unordered_map<string, int>parkTime;
int dtmax = -1;
vector<string>longest;
for(int i = 1; i < n; ++i){
if(strcmp(v[i - 1].id, v[i].id) == 0 && v[i - 1].tag == 0 && v[i].tag == 1){
car temp;
strcpy(temp.id, v[i - 1].id);
temp.in = v[i - 1].t;
temp.out = v[i].t;
ans.push_back(temp);
string str = temp.id;
if(parkTime.count(str) == 0)parkTime[str] = 0;
parkTime[str] += (temp.out - temp.in);
if(parkTime[str] > dtmax){
longest.clear();
longest.push_back(str);
dtmax = parkTime[str];
}else if(parkTime[str] == dtmax){
longest.push_back(str);
}
}
}
sort(ans.begin(), ans.end());
for(int i = 0; i < m; ++i){
int hh, mm, ss;
scanf("%d:%d:%d", &hh, &mm, &ss);
int t = hh * 3600 + mm * 60 + ss;
int cnt = 0;
for(int j = 0; j < ans.size() && t >= ans[j].in ; ++j){
if(t < ans[j].out)cnt++;
}
printf("%d\n", cnt);
}
for(int i = 0; i < longest.size(); ++i){
printf("%s ", longest[i].c_str());
}
printf("%02d:%02d:%02d", dtmax / 3600, dtmax % 3600 / 60, dtmax % 60);
return 0;
}

最新文章

  1. adb connect 出现timeout的处理方式
  2. Ubuntu下更改网卡名称
  3. PlantUML的实例参考
  4. 我这样理解js里的this
  5. 如何避免Activity 被杀死
  6. Flesch Reading Ease (poj 3371)
  7. Javascript Regexp match and replace
  8. VS2012减负:加快启动速度,减少编辑卡壳
  9. 舶来品P2P理财 能否成为“好声音”式好生意? 转
  10. C++_基础_类和对象3
  11. swift 定位 根据定位到的经纬度转换城市名
  12. 动态代理的两种实现方式(JDK/Cglib)
  13. Linux计划任务及压缩归档
  14. Linux 驱动——Button驱动1
  15. Windows下安装单机Kafka
  16. 极光推送java代码
  17. 理解 DocumentFragment
  18. [转]pugixml使用教程
  19. [转]sp_OACreate WriteLine Writing nvarchar 中文汉字 非乱码to a text file
  20. Could not read symbols解决方法

热门文章

  1. 七种可能 | Linux丢包故障的定位与解决
  2. Nginxre quest_time 和upstream_response_time
  3. Nginx中配置反向代理的proxy_pass的不同斜杠的区别
  4. JAVA微信公众号网页开发——生成自定义微信菜单(携带参数)
  5. SpringBoot统一日志打印
  6. Dapr项目应用探索
  7. 【LeetCode】461. Hamming Distance 解题报告(java & python)
  8. C. The Meaningless Game
  9. Anniversary party(hdu1520)
  10. [炼丹术]EfficientDet训练模型学习总结