L - One-Dimensional Maze

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description

BaoBao is trapped in a one-dimensional maze consisting of \(n\) grids arranged in a row! The grids are numbered from 1 to \(n\) from left to right, and the \(i\)-th grid is marked with a character \(s_i\), where \(s_i\) is either 'L' or 'R'.

Starting from the \(m\)-th grid, BaoBao will repeatedly take the following steps until he escapes the maze:

  • If BaoBao is in the 1st grid or the \(n\)-th grid, then BaoBao is considered to arrive at the exit and thus can escape successfully.
  • Otherwise, let BaoBao be in the \(t\)-th grid. If \(s_t = \text{'L'}\), BaoBao will move to the \((t-1)\)-th grid; If \(s_t = \text{'R'}\), Baobao will move to the \((t+1)\)-th grid.

Before taking the above steps, BaoBao can change the characters in some grids to help himself escape. Concretely speaking, for the \(i\)-th grid, BaoBao can change \(s_i\) from 'L' to 'R', or from 'R' to 'L'.

But changing characters in grids is a tiring job. Your task is to help BaoBao calculate the minimum number of grids he has to change to escape the maze.

Input

There are multiple test cases. The first line of the input contains an integer \(T\), indicating the number of test cases. For each test case:

The first line contains two integers \(n\) and \(m\) (\(3 \le n \le 10^5\), \(1 < m < n\)), indicating the number of grids in the maze, and the index of the starting grid.

The second line contains a string \(s\) (\(|s| = n\)) consisting of characters 'L' and 'R'. The \(i\)-th character of \(s\) indicates the character in the \(i\)-th grid.

It is guaranteed that the sum of \(n\) over all test cases will not exceed \(10^6\).

Output

For each test case output one line containing one integer, indicating the minimum number of grids BaoBao has to change to escape the maze.

Sample Input

3
3 2
LRL
10 4
RRRRRRRLLR
7 4
RLLRLLR

Sample Output

0
2
1

Hint

For the first sample test case, BaoBao doesn't have to change any character and can escape from the 3rd grid. So the answer is 0.

For the second sample test case, BaoBao can change \(s_8\) to 'R' and \(s_9\) to 'R' and escape from the 10th grid. So the answer is 2.

For the third sample test case, BaoBao can change \(s_4\) to 'L' and escape from the 1st grid. So the answer is 1.

题意:给出一串只有RL的字符串,
给定起始位置,R表示向右,L表示向左,
现在要求输出最少改变几个字符可以移动到字符第一个或者最后一个。
例如:
6 3
LLRRLR
起始位置是第三个字符R,只用改变第三个R就可以到达第一个字符L
这道题目通过模拟就可以做出来,
就是将到达两边要改变的字符都求出来,输出最小的那个

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define max_v 100005
char str[max_v];
/*
Submit Failed
*/
int main()
{
int t;
int n,m,sum1,sum2;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
scanf("%s",str+);
sum1=;
sum2=;
for(int i=m;i<n;i++)
if(str[i]=='L')
sum1++;
for(int i=m;i>;i--)
if(str[i]=='R')
sum2++;
printf("%d\n",min(sum1,sum2));
}
return ;
}
/*
题意:给出一串只有RL的字符串,
给定起始位置,R表示向右,L表示向左,
现在要求输出最少改变几个字符可以移动到字符第一个或者最后一个。
例如:
6 3
LLRRLR 起始位置是第三个字符R,只用改变第三个R就可以到达第一个字符L
这道题目通过模拟就可以做出来,
就是将到达两边要改变的字符都求出来,输出最小的那个 */
 

最新文章

  1. Apache mod_rewrite规则重写的标志一览
  2. OSTimeDelay(1)
  3. 2D多边形碰撞器优化器
  4. BZOJ2741: 【FOTILE模拟赛】L
  5. 嵌入式web server——Goahead启用SSL
  6. hibernate的get、load的方法的区别,IllegalArgument异常
  7. hdu 3530 Subsequence 单调队列
  8. 利用Pattern和Mather来禁止特殊字符的输入
  9. UVA The Sultan&amp;#39;s Successors
  10. 选择 GCD 还是 NSTimer
  11. iOS11和机器学习CoreML库
  12. Rhythmbox音乐播放器常见问题
  13. hdu 4751 Divide Groups bfs (2013 ACM/ICPC Asia Regional Nanjing Online 1004)
  14. Xamarin Android Fragment的两种加载方式
  15. CDuiString和String的转换
  16. SFTP文件服务器的搭建
  17. 获得小程序码getWXACodeUnlimit
  18. 概率DP求解例题
  19. 研究傅里叶变换的一本好书&lt;&lt;快速傅里叶变换及其C程序&gt;&gt;
  20. CSS 边框图像

热门文章

  1. Tomcat启动中文乱码解决方法
  2. PHP的new self() 与new static()
  3. react 实现在调父render时,子组件会重新更新
  4. react组件里阻事件冒泡
  5. JS 时间转化为几分钟前 几小时前 几天前
  6. 图形报表部署在Linux下出现乱码解决办法
  7. java 接口默认修饰符
  8. deep learning深度学习之学习笔记基于吴恩达coursera课程
  9. leveldb源码分析--插入删除流程
  10. linux上设置mysql编码