Savings Account

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 779    Accepted Submission(s): 545

Problem Description
Suppose you open a savings account with a certain initial balance. You will not make any withdrawals or further deposits for a number of years. The bank will compound your balance (add the annual interest) once a year, on the anniversary of the opening of the account. Your goal is to achieve a certain target amount in your savings account. In how may years will the target amount be achieved?
 
Input
The input file will contain data for one or more test cases, one test case per line. Each line will contain three numbers: the initial balance, the annual interest rate (as a percentage of the balance), and the target amount, separated by blank spaces. These will be positive numbers; they may or may not contain a decimal point. The target amount will be greater than the initial balance. The input is terminated by end-of-file
 
Output
For each line of input, your program will produce exactly one line of output: This line will contain one positive integer value: the number of years required to achieve the target amount.
 
Sample Input
200.00 6.5 300 500 4 1000.00
 
Sample Output
7 18
 
Author
2006Rocky Mountain Warmup
 
Source
水体:
代码:
 #include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
double a,r,tot;
int cnt=;
while(scanf("%lf%lf%lf",&a,&r,&tot)!=EOF)
{
r/=;
while(tot-a>1.0e-8)
{
cnt++;
a*=(r+);
}
printf("%d\n",cnt);
cnt=;
}
return ;
}

最新文章

  1. HibernateSessionFactory建立-使用ThreadLocal
  2. 更换mysql数据目录后出现ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) 的解决办法
  3. js-格式化数字保留两位小数-带千分符
  4. POJ 2479
  5. .Net core Linux环境安装
  6. python3 入门 (一) 基础语法
  7. epoll重要
  8. DFS+剪枝 HDOJ 5323 Solve this interesting problem
  9. javascript 递归调用
  10. Slickflow.NET 开源工作流引擎基础介绍(三) -- 基于HTML5/Bootstrap的Web流程设计器
  11. Java基础知识强化之IO流笔记59:打印流
  12. session相关----高手请跳过!
  13. USB 设备插拔事件处理
  14. Dialog样式的Activity
  15. Tensorflow datasets.shuffle repeat batch方法
  16. leecode第六十一题(旋转链表)
  17. Swift5 语言参考(四) 表达式
  18. spring中获取ApplicationContext对象的技巧,含源码说明
  19. Linux运维之shell脚本基础知识
  20. php + crontab 执行定时任务

热门文章

  1. 《逆袭大学:传给IT学子的正能量》
  2. sql递归查询子级
  3. C语言编程规范
  4. uva 10618 Tango Tango Insurrection 解题报告
  5. C++的Vector用法
  6. Tengine zabbix 监控
  7. iOS开发-简单的图片查看器
  8. MSSQL工作中常用的小技巧
  9. COM中的几个基本概念
  10. Python-__builtin__与__builtins__的区别与关系(超详细,经典)(转)