Jungle Roads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 25993   Accepted: 12181

Description




The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The
Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads,
even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through
I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 


Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet,
capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to
villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road.
Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more
than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute
time limit. 

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Source

——————————————————————————————————————

题目的意思是在给出的一张图中找出一棵最小生成树。

建图后kruskal即可

#include <iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<set>
using namespace std;
#define LL long long struct node
{
int u,v,w;
} p[100005];
int n,cnt,pre[100]; bool cmp(node a,node b)
{
return a.w<b.w;
}
void init()
{
for(int i=0;i<100;i++)
pre[i]=i;
} int fin(int x)
{
return pre[x]==x?x:pre[x]=fin(pre[x]);
} void kruskal()
{
sort(p,p+cnt,cmp);
init();
int cost=0,ans=0,flag=0;
for(int i=0;i<cnt;i++)
{
int a=fin(p[i].u);
int b=fin(p[i].v);
if(a!=b)
{
pre[a]=b;
cost+=p[i].w;
ans++;
}
if(ans==n-1)
{
break;
}
} printf("%d\n",cost);
} int main()
{
char ch1,ch2;
int k,val;
while(~scanf("%d",&n)&&n)
{
cnt=0;
for(int i=0; i<n-1; i++)
{
cin>>ch1>>k;
for(int j=0; j<k; j++)
{
cin>>ch2>>val;
p[cnt].u=ch1-'A',p[cnt].v=ch2-'A',p[cnt++].w=val;
}
}
kruskal();
}
return 0;
}

最新文章

  1. Installation error: INSTALL_FAILED_NO_MATCHING_ABIS
  2. JSP的9大内置对象
  3. Android开发之Touch事件分发机制
  4. Live2D WebGL实现
  5. javaweb项目springmvc,和tomcat对静态文件的处理
  6. 【noiOJ】p1794
  7. ueditor样式过滤问题
  8. OpenCV2学习笔记05:矩阵翻转
  9. Linux下aMule安装教程
  10. text-overflow简单使用
  11. HttpApplication实战大文件上传 (第四篇)
  12. php 数组 array_intersect_key() array_unique()移除重复
  13. 基于visual Studio2013解决C语言竞赛题之1006填空
  14. Hashtable、synchronizedMap、ConcurrentHashMap 比较
  15. Kinect SDK2.0 + OpenCV 3.0 抠人,换背景
  16. Mac休眠后解决卡死转圈问题
  17. ZYNQ DMA驱动及测试分析
  18. vue的$nextTick使用总结,this.$refs为undefined的解决办法,element Ui的树形控件setCheckedKeys方法无法使用
  19. csv与xlsx导出
  20. BZOJ 4032: [HEOI2015]最短不公共子串

热门文章

  1. OpenLTE安装教程
  2. 如何查看oracle表空间是否自动扩展
  3. T4模板批量生成代码文件
  4. bzoj 3965: [WF2011]Pyramids
  5. django-model的元类Meta
  6. ES6系列_5之字符串模版
  7. How to create a site with AJAX enabled in MVC framework.
  8. spring data jpa、 hibernate、 jpa 三者之间的关系
  9. 规则引擎以及blaze 规则库的集成初探之二——JSR94 的规则引擎API和实现
  10. orchard cms 项目迁移