Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing
in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected
in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 - 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B - numbers of currencies it exchanges,
and real R AB, C AB, R BA and C BA - exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative
sum of money while making his operations. 

Input

The first line of the input contains four numbers: N - the number of currencies, M - the number of exchange points, S - the number of currency Nick has and V - the quantity of currency units he has. The following M lines contain
6 numbers each - the description of the corresponding exchange point - in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 -2<=rate<=10 2, 0<=commission<=10 2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations
will be less than 10 4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意:

就是不同的货币换来换去 有汇率和手续费 问能不能换来换去换来换去把自己的钱变多

思路:

某些节点可以不停地重复 因为是增值的 增值到一定程度以后再往回肯定是可行的

刚开始不知道要怎么存图  最后用的结构体 设了边

然后不知道怎么判断到达某样的条件就可以成功

看了题解 只用判断存在环就可以了

如果回到原来的货币已经比开始的大了就可以直接退出了

改变一下松弛条件

double t = (d[point[j].beg] - point[j].c) * point[j].r;

    if(d[point[j].ed] < t){

        d[point[j].ed] = t;

        return true;

    }

    return false;

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<cstring>
#include<queue>
#include<stack>
#define inf 0x3f3f3f3f using namespace std; int n, m, s, point_num;
double v;
struct edge{
int beg, ed;
double r, c;
}point[210];
double d[205]; void addpoint(int beg, int ed, double r, double c)
{
point[point_num].beg = beg;
point[point_num].ed = ed;
point[point_num].r = r;
point[point_num].c = c;
point_num++;
} bool relax(int j)
{
double t = (d[point[j].beg] - point[j].c) * point[j].r;
if(d[point[j].ed] < t){
d[point[j].ed] = t;
return true;
}
return false;
} bool bellman_ford()
{
for(int i = 1; i <= n; i++){
d[i] = 0.0;
}
d[s] = v;
for(int i = 0; i < n - 1; i++){
bool flag = false;
for(int j = 0; j < point_num; j++){
if(relax(j)) flag = true;
}
if(d[s] > v) return true;
if(!flag) return false;
}
for(int i = 0; i < point_num; i++){
if(relax(i)) return true;
}
return false;
} int main()
{
while(cin>>n>>m>>s>>v){
point_num = 0;
for(int i = 0; i < m; i++){
int a, b;
double ra, ca, rb, cb;
cin>>a>>b>>ra>>ca>>rb>>cb;
addpoint(a, b, ra, ca);
addpoint(b, a, rb, cb);
} if(bellman_ford()){
cout<<"YES"<<endl;
}
else{
cout<<"NO"<<endl;
}
}
return 0;
}

最新文章

  1. 最新版powerdesign16.5连接数据库错误解决
  2. JavaScript链表
  3. linux下RDP客户端及服务器
  4. WPF自定义控件与样式(6)-ScrollViewer与ListBox自定义样式
  5. 第1/24周 SQL Server 如何执行一个查询
  6. java实现八皇后问题(递归和循环两种方式)
  7. JNI字段描述符(转)
  8. 83. Remove Duplicates from Sorted List
  9. Python函数中参数* 和 ** 的区别
  10. 网站项目:让一般处理文件.ashx的代码有折叠功能(#region)
  11. 一維條碼 EAN13 的編碼方式
  12. Android:assests和raw的区别
  13. SpringBoot入门Demo
  14. 转:java中Vector的使用
  15. 滴滴 App 的质量优化框架 Booster,开源了!
  16. 洛谷P3195 玩具装箱
  17. Asp.Net Core 发布异常 502.5 [The Application process failed to Start]
  18. canvas学习-----画直线
  19. go build -ldflags
  20. redis的哨兵模式

热门文章

  1. Install VMware Workstation as a Service
  2. mybatis 之 parameterType=&quot;java.util.HashMap&quot;&gt;
  3. JQuery插件的使用
  4. 《C++ Primer Plus》16.3 标准模板库 学习笔记
  5. Servlet基本用法(二)接口和类
  6. 理解Java的反射与内省及其区别
  7. 清理和关闭多余的Windows 7系统服务
  8. Python学习(25):Python执行环境
  9. Python Tkinter 学习成果:点歌软件music
  10. 怎样在excel中快速输入当前日期和时间