【BZOJ3943】[Usaco2015 Feb]SuperBull

Description

Bessie and her friends are playing hoofball in the annual Superbull championship, and Farmer John is in charge of making the tournament as exciting as possible. A total of N (1 <= N <= 2000) teams are playing in the Superbull. Each team is assigned a distinct integer team ID in the range 1...2^30-1 to distinguish it from the other teams. The Superbull is an elimination tournament -- after every game, Farmer John chooses which team to eliminate from the Superbull, and the eliminated team can no longer play in any more games. The Superbull ends when only one team remains.Farmer John notices a very unusual property about the scores in
matches! In any game, the combined score of the two teams always ends up being the bitwise exclusive OR (XOR) of the two team IDs. For example, if teams 12 and 
20 were to play, then 24 points would be scored in that game, since 01100 XOR 10100 = 11000.Farmer John believes that the more points are scored in a game, the more exciting the game is. Because of this, he wants to choose a series of games to be played such that the total number of points scored in the Superbull is maximized. Please help Farmer John organize the matches.
贝西和她的朋友们在参加一年一度的“犇”(足)球锦标赛。FJ的任务是让这场锦标赛尽可能地好看。一共有N支球队参加这场比赛,每支球队都有一个特有的取值在1-230-1之间的整数编号(即:所有球队编号各不相同)。“犇”锦标赛是一个淘汰赛制的比赛——每场比赛过后,FJ选择一支球队淘汰,淘汰了的球队将不能再参加比赛。锦标赛在只有一支球队留下的时候就结束了。FJ发现了一个神奇的规律:在任意一场比赛中,这场比赛的得分是参加比赛两队的编号的异或(Xor)值。例如:编号为12的队伍和编号为20的队伍之间的比赛的得分是24分,因为 12(01100) Xor 20(10100) = 24(11000)。FJ相信比赛的得分越高,比赛就越好看,因此,他希望安排一个比赛顺序,使得所有比赛的得分和最高。请帮助FJ决定比赛的顺序

Input

The first line contains the single integer N. The following N lines contain the N team IDs.
第一行包含一个整数N接下来的N行包含N个整数,第i个整数代表第i支队伍的编号, 1<=N<=2000

Output

Output the maximum possible number of points that can be scored in the Superbull.
一行,一个整数,表示锦标赛的所有比赛的得分的最大值

Sample Input

4
3
6
9
10

Sample Output

37

HINT

样例解释:
FJ先让编号为3和编号为9的队伍进行比赛,然后让编号为9的队伍赢得比赛(淘汰编号为6的队伍),现在
剩下了编号为6910的队伍。然后他让编号为6和编号为9的队伍比赛,然后让编号为6的队伍赢得比赛。现在编号为6
10的队伍留了下来最后让编号为6和编号为10的队伍比赛,让编号为10的队伍赢得比赛。所有比赛的得分和就是:(
3Xor9)+(6Xor9)+(6Xor10)=10+15+12=37

题解:本题看起来很麻烦,但我们发现n只有2000,于是想到可以把所有牛当成点,所有比赛当成边,然后跑一遍最大生成树就可以了。

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n,m,sum;
long long ans;
struct match
{
int from,to,val;
}s[2010*2010];
int p[2010],f[2010];
bool cmp(match a,match b)
{
return a.val>b.val;
}
int find(int x)
{
if(f[x]!=x)
f[x]=find(f[x]);
return f[x];
}
int main()
{
scanf("%d",&n);
int i,j,ra,rb;
for(i=1;i<=n;i++)
{
f[i]=i;
scanf("%d",&p[i]);
for(j=1;j<i;j++)
{
s[m].from=j;
s[m].to=i;
s[m++].val=p[i]^p[j];
}
}
sort(s,s+m,cmp);
for(i=0;i<m;i++)
{
ra=find(s[i].from);
rb=find(s[i].to);
if(ra!=rb)
{
f[ra]=rb;
ans+=(long long)s[i].val;
sum++;
if(sum==n-1)
break;
}
}
printf("%lld",ans);
return 0;
}

最新文章

  1. 利用Cayley-Hamilton theorem 优化矩阵线性递推
  2. SharePoint中的ASHX
  3. CGPoint、CGSize、CGRect and UIView
  4. JavaScript的学习--正则表达式
  5. NODE.JS的基本系统模块操作样例
  6. Head First 设计模式系列之一----模板模式(java版)
  7. mac 神奇时光机
  8. MVC route 和 Angular router 单页面的一些方式
  9. win10系统加载ahci驱动的操作方案(Win10之家)
  10. 网络视频传输的服务质量(QoS)
  11. The Super Powers
  12. Python爬虫之ip代理池
  13. Delphi中Move、CopyMemory操作
  14. Office365维护命令
  15. CentOS7 上以 RPM 包方式安装 Oracle 18c 单实例
  16. mysql中外键的创建与删除
  17. Java的赋值、浅克隆和深度克隆的区别
  18. python selenium截取指定元素图片
  19. 【impala学习之一】impala
  20. JAVA中获取文件MD5值的方法

热门文章

  1. 使用Backbone构建精美应用的7条建议
  2. C++ 继承、函数重载
  3. Servlet程序的入口点是?( )
  4. URI、URL和URN之间的区别
  5. 深入了解Android蓝牙Bluetooth ——《总结篇》
  6. endl的读法
  7. dom元素改变监听
  8. Ajax在ASP.NET MVC中上传
  9. 编写高性能的jQuery代码
  10. 7 -- Spring的基本用法 -- 3... Spring 的核心机制 : 依赖注入