Talented Chef

Time Limit: 2 Seconds Memory Limit: 65536 KB

As we all know, Coach Gao is a talented chef, because he is able to cook M dishes in the same time. Tonight he is going to have a hearty dinner with his girlfriend at his home. Of course, Coach Gao is going to cook all dishes himself, in order to show off his genius cooking skill to his girlfriend.

To make full use of his genius in cooking, Coach Gao decides to prepare N dishes for the dinner. The i-th dish contains Aii steps. The steps of a dish should be finished sequentially. In each minute of the cooking, Coach Gao can choose at most MMM different dishes and finish one step for each dish chosen.

Coach Gao wants to know the least time he needs to prepare the dinner.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1<=N,M<=40000). The second line contains N integers Ai(1<=Ai<=40000).

Output

For each test case, output the least time (in minute) to finish all dishes.

Sample Input

2
3 2
2 2 2
10 6
1 2 3 4 5 6 7 8 9 10

Sample Output

3
10

题意

有n个菜,做每个菜需要ai​步,每次最多可以做m个菜,求做完这n个菜最少需要多少时间

Solve

先提供一个超时的思路:将n个菜按照ai​降序排序,排序后每次取出前m个菜,然后让这m个菜一直减到取出的最小的aii小于未取出的n−m个菜的最大的ai,然后将减少后的不等于0的ai放入序列中,重复上述操作,直到n个数全部为0。

时间复杂度大概为O(n×m)

不超时的算法

将所有的ai加起来,sum=∑ai​,然后sum除以m向上取整。

但是只有这样是不正确的:如果出现了⌈sum/m​⌉<max(ai)的情况,那么所需的时间一定不会小于ai中的最大值,所以我们需要比较⌈sum/m⌉和max(ai)的值


证明:点这里吧,不太会证明。程序是照着超时的思路对拍出来的

Code

超时代码在最后

AC代码

#include <bits/stdc++.h>
#define ll long long
#define ull unsigned long long
#define ms(a,b) memset(a,b,sizeof(a))
const int inf=(1<<30);
const ll INF=(1LL*1<<60);
const int maxn=1e6+10;
const int mod=1e9+7;
const int maxm=1e3+10;
using namespace std;
int main(int argc, char const *argv[])
{
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
freopen("out1.txt", "w", stdout);
#endif
ios::sync_with_stdio(false);
cin.tie(0);
int t;
cin>>t;
while(t--)
{
int n,m;
ll x;
cin>>n>>m;
ll sum=0;
ll maxx=0;
for(int i=0;i<n;i++)
{
cin>>x;
maxx=max(maxx,x);
sum+=x;
}
ll _=(sum - 1)/(1LL*m)+1;
cout<<max(maxx,_)<<endl;
}
return 0;
}

超时代码

/*************************************************************************

	 > Author: WZY
> School: HPU
> Created Time: 2019-04-20 09:07:07 ************************************************************************/
#include<bits/stdc++.h>
using namespace std;
const int maxn = 4e4 + 10;
int a[maxn];
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt", "r", stdin);
freopen("out2.txt", "w", stdout);
#endif
int t;
int x;
scanf("%d",&t);
while (t --)
{
int ans=0;
int n,m;
priority_queue<int,vector<int>,less<int> > que;
scanf("%d %d",&n,&m);
for (int i = 0;i < n;i ++)
{
scanf("%d",&x);
que.push(x);
}
while(!que.empty())
{
int cnt=0;
int minn;
for(int i=0;i<m;i++)
{
minn=que.top();
que.pop();
a[cnt++]=minn;
if(que.empty())
break;
}
int maxx;
if(que.empty())
maxx=0;
else
maxx=que.top();
int __=max(1,minn-maxx);
ans+=max(1,minn-maxx);
for(int i=0;i<cnt;i++)
{
a[i]=max(a[i]-__,0);
if(a[i])
que.push(a[i]);
}
}
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. container 的背后
  2. 剑指offer—第三章高质量的代码(按顺序打印从1到n位十进制数)
  3. Memcached(三)Memcached配置参数初解
  4. ANDROID_MARS学习笔记_S04_006_用获取access_token,access_token_secrect
  5. linux c最简单的加密程序
  6. css样式小记
  7. JAVA_SE基础——72.自定义线程
  8. mybatis加载属性
  9. An error occurred while updating the entries. See the inner exception for details.
  10. 动态切换 web 报表中的统计图类型
  11. Linux系统学习之软件安装
  12. [UE4]装饰器:Blackboard(装饰器的一种,不是黑板)
  13. java中三种注释
  14. 多个div中的label标签对齐
  15. vbs常用函数
  16. Scala2.11.8 spark2.3.1 mongodb connector 2.3.0
  17. 【微服务架构】SpringCloud之Ribbon
  18. OI数据结构&amp;&amp;分治 简单学习笔记
  19. hexo&amp;github博客搭建
  20. decorator & generator & iterator

热门文章

  1. JavaScript | 新手村(一)变量,运算和变量方法
  2. CAS你知道吗
  3. Mybatis 批量插入
  4. Linux学习 - 系统命令sudo权限
  5. Can a C++ class have an object of self type?
  6. VFL
  7. redis入门到精通系列(九):redis哨兵模式详解
  8. 02_ubantu常用软件安装
  9. HTML DOM 对象 - 方法和属性
  10. C/C++ Qt 数据库SqlRelationalTable关联表