Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color
and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case
letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
 

Sample Output

red
pink
这题用map做了一下,算是入门吧。

#include<stdio.h>
#include<iostream>
#include<string> //这里一定要写
#include<string.h>
#include<map>
#include<algorithm>
using namespace std;
//string s;
char s[2300][100],str[2000];
int main()
{
int n,m,i,j,max;
map<string,int>hash;
map<string,int>::iterator it,p;
while(scanf("%d",&n)!=EOF && n!=0)
{
hash.clear();
memset(str,0,sizeof(str));
for(i=1;i<=n;i++){
//cin>>s;
scanf("%s",s[i]);
hash[s[i]]++;
}
max=0;
for(it=hash.begin();it!=hash.end();it++ ){
if(it->second>max){
max=it->second;
p=it;
}
}
cout<<p->first<<endl;
}
return 0;
}

最新文章

  1. sql server 对象资源管理器(二)
  2. WPF打包32位和64位程序 运行在ghost WIN7上问题
  3. angularjs backbone 集成requirejs 模块化
  4. singleTask, singleInstance使用心得
  5. Jdbc如何从PostgreSql读取海量数据?PostgreSql源代码分析纪录
  6. asp.net将数据库中的数据赋给DropDownList
  7. Play on Words
  8. Election Time
  9. 使用Gradle构建Android应用内测版本
  10. github如何搜索资料
  11. JavaEE中的MVC(二)Xml配置实现IOC控制反转
  12. 在应用中更新App版本号
  13. Mybatis的缓存
  14. hibernate框架中注意的几个问题
  15. MUI手势锁
  16. try_files
  17. php 中self,this的区别和实地操作
  18. 洛谷P1337 【[JSOI2004]平衡点 / 吊打XXX】(模拟退火)
  19. px转rem
  20. python -猜字小游戏

热门文章

  1. LeetCode222 判断是否为完全二叉树并求节点个数
  2. oracle 11g 安装与卸载
  3. React &amp; Vue2 Butterfly图编排——让数据更自由地驱动DAG
  4. VSCode运行时弹出powershell
  5. 绝对定位上下左右都为0 margin为auto为什么能居中
  6. Trino总结
  7. django 组件 自定义过滤器 自定义标签 静态文件配置
  8. 为失败设计,大量引入对SRE的理解,鲁棒性高
  9. udp 连接
  10. 内联扩展 inline expansion An Inline Function is As Fast As a Macro 与宏的比较