Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2382    Accepted Submission(s): 933

Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is
larger than another if and only if the total value of the edges is greater than another one’s.


 
Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers,
u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.

The last test case is followed by a line containing two zeros, which means the end of the input.
 
Output
Output the sum of the value of the edges of the maximum pesudoforest.
 
Sample Input
3 3
0 1 1
1 2 1
2 0 1
4 5
0 1 1
1 2 1
2 3 1
3 0 1
0 2 2
0 0
 
Sample Output
3 5 求出一个最大的子图(子图的每个连通分量最多有一个环) 用kruskal算法求出最大生成树  不过要判断是否有环  2树合并时 :若2个子树都有环不能合并 只有一个有环可以合并 但合并后的树有环 若2个子树都没环直接合并
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <math.h>
#include <algorithm>
#include <stdio.h> using namespace std;
#define MAX 10000
int n,m;
struct Node
{
int x;
int y;
int w;
}a[MAX*10+5];
int father[MAX+5];
bool tag[MAX+5];
int cmp(Node a,Node b)
{
return a.w>b.w;
}
int find(int x)
{
if(x!=father[x])
father[x]=find(father[x]);
return father[x];
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
for(int i=0;i<m;i++)
scanf("%d%d%d",&a[i].x,&a[i].y,&a[i].w);
for(int i=0;i<n;i++)
{
father[i]=i;
tag[i]=false;
}
sort(a,a+m,cmp);
int ans=0;
for(int i=0;i<m;i++)
{
int xx=find(a[i].x);
int yy=find(a[i].y);
if(xx!=yy)
{
if(tag[xx]&&tag[yy])
continue;
ans+=a[i].w;
father[xx]=yy;
if(tag[xx]||tag[yy])
{tag[xx]=true;tag[yy]=true;}
}
else
{
if(tag[xx]||tag[yy])
continue;
ans+=a[i].w;
tag[xx]=true;tag[yy]=true;
}
}
printf("%d\n",ans);
}
return 0;
}

最新文章

  1. awk命令简介
  2. python3下载远程代码并执行
  3. Hadoop 2.5.1编译
  4. [转] 如何设置Eclipse的上网代理
  5. ( 译、持续更新 ) JavaScript 上分小技巧(四)
  6. 多重背包问题:POJ2392
  7. Activity按下2次退出和获取当前时间
  8. P2312 解方程
  9. TCL随记(1)
  10. myloader原理0
  11. load-store/register-memory/register-plus-memory比较
  12. android音乐播放器开发 SweetMusicPlayer 实现思路
  13. JQuery插件使用小结
  14. 关于 Go 中 Map 类型和 Slice 类型的传递
  15. Django入门之路
  16. easyui datagrid 后台分页,前端如何处理
  17. JavaSE基础知识(5)—面向对象(Object类)
  18. Jquery EasyUI Combotree根据选中的值展开所有父节点
  19. Python openpyxl、pandas操作Excel方法简介与具体实例
  20. mysql 通过查看mysql 配置参数、状态来优化你的mysql

热门文章

  1. Excel去除单元格中的汉字
  2. php学记笔记之函数用途
  3. MySQL监控脚本
  4. hdu1243 最长公共子序列(LCS)
  5. Atitti.数据操作crud js sdk dataServiceV3设计说明
  6. DDR 复位
  7. 分页技术框架(Pager-taglib)学习二(SSH数据库分页)
  8. Python 函数常用方法总结
  9. Itunes connect上传应用视频 app preview时遇到“无法载入文件”的问题
  10. 清理iOS中的&ldquo;其他&rdquo;空间垃圾文件