https://pintia.cn/problem-sets/994805342720868352/problems/994805504927186944

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

 W    T    L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be ( yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to WT and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

代码:

#include <bits/stdc++.h>
using namespace std; struct Game{
double w;
double t;
double l;
double maxx;
char res;
}game[10010]; int main() {
for(int i = 1; i <= 3; i ++) {
scanf("%lf%lf%lf", &game[i].w, &game[i].t, &game[i].l);
game[i].maxx = max(max(game[i].w, game[i].t), game[i].l);
if(game[i].maxx == game[i].w) game[i].res = 'W';
else if(game[i].maxx == game[i].t) game[i].res = 'T';
else game[i].res = 'L';
} double money = 1;
for(int i = 1; i <= 3; i ++) {
money *= game[i].maxx;
}
money = (money * 0.65 - 1) * 2; for(int i = 1; i <= 3; i ++)
printf("%c ", game[i].res);
printf("%.2lf\n", money); return 0;
}

  

最新文章

  1. 几个Web server的HA架构资料
  2. MSSQL数字时间(timestamp)转换为DATETIME
  3. [cocos2d]调用sqlite3数据库
  4. 从ZOJ2114(Transportation Network)到Link-cut-tree(LCT)
  5. 通宵疯狂积累VB.NET基础知识
  6. unity中锁定鼠标移动&amp;&amp;隐藏鼠标&amp;&amp;强制是鼠标移动到某一位置
  7. PHP中引入文件的四种方式及区别
  8. MyBatis入门简述
  9. 批量找注入 python3+sqlmap结合
  10. asp.net mvc5 多语言应用
  11. SimInfo获取(MCC, MNC, PLMN)
  12. highcharts,highStock 中文图表配置
  13. Python中的基本语法
  14. go语言之进阶篇方法值
  15. UNIX环境编程学习笔记(18)——进程管理之进程控制三部曲
  16. C中入栈顺序和运算顺序有关系吗?
  17. kmp java implement--转
  18. 【VBA编程】02.调试VBA程序
  19. c语言-单链表(二)
  20. 【马克-to-win】—— 学习笔记

热门文章

  1. Drupal 新建Modules
  2. 配置伪静态(URL重写)
  3. FTP服务安装及使用
  4. CTS、CLS、CLR分别作何解释?
  5. computed--实时计算属性
  6. Redis 4.0 从节点写入不同步问题
  7. mysql的jdbc.url携带allowMultiQueries=true参数的作用及其原理
  8. aop设计原理
  9. CodeMirror的使用方法
  10. 关于sql server 2008 r2 展开时报错:参数名:viewInfo ( Microsoft SqlServer Management SqlStudio Explorer )解决思路