【BZOJ1731】[Usaco2005 dec]Layout 排队布局

Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

当排队等候喂食时,奶牛喜欢和它们的朋友站得靠近些。FJ有N(2<=N<=1000)头奶牛,编号从1到N,沿一条直线站着等候喂食。奶牛排在队伍中的顺序和它们的编号是相同的。因为奶牛相当苗条,所以可能有两头或者更多奶牛站在同一位置上。即使说,如果我们想象奶牛是站在一条数轴上的话,允许有两头或更多奶牛拥有相同的横坐标。一些奶牛相互间存有好感,它们希望两者之间的距离不超过一个给定的数L。另一方面,一些奶牛相互间非常反感,它们希望两者间的距离不小于一个给定的数D。给出ML条关于两头奶牛间有好感的描述,再给出MD条关于两头奶牛间存有反感的描述。(1<=ML,MD<=10000,1<=L,D<=1000000)你的工作是:如果不存在满足要求的方案,输出-1;如果1号奶牛和N号奶牛间的距离可以任意大,输出-2;否则,计算出在满足所有要求的情况下,1号奶牛和N号奶牛间可能的最大距离。

Input

* Line 1: Three space-separated integers: N, ML, and MD. * Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart. * Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

* Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3
INPUT DETAILS:
There are 4 cows. Cows #1 and #3 must be no more than 10 unitsapart, cows #2 and #4 must be no more than 20 units apart, and cows#2 and #3 dislike each other and must be no fewer than 3 units apart.

Sample Output

27
四只牛分别在0,7,10,27.

题解:闲着没事刷刷水~

先根据题中给的条件建出边,然后跑从1开始的最短路(注意不是最长路,因为每一条边代表的不是距离,是限制,所以最短路就是刚好满足所有限制的最长路),如果有负环,说明无法满足所有条件;如果没有更新到点n,说明1-n没有限制,可以无现长;否则答案就是最短路。

P.S.本人只跑了一遍最短路,可能有些无解的情况找不出来,所以应该先判无解,再判能否到n。然而数据比较水~

#include <cstdio>
#include <cstring>
#include <iostream>
#include <queue>
using namespace std;
int n,m1,m2,cnt;
int to[100000],next[100000],val[100000],head[1010],dis[1010],len[1010],inq[1010];
int pa[20010],pb[20010],pc[20010];
queue<int> q;
void add(int a,int b,int c)
{
to[cnt]=b,val[cnt]=c,next[cnt]=head[a],head[a]=cnt++;
}
int main()
{
scanf("%d%d%d",&n,&m1,&m2);
int i,u,a,b,c;
memset(head,-1,sizeof(head));
for(i=2;i<=n;i++) add(i,i-1,0);
for(i=1;i<=m1;i++)
{
scanf("%d%d%d",&a,&b,&c);
add(a,b,c);
}
for(i=1;i<=m2;i++)
{
scanf("%d%d%d",&a,&b,&c);
add(b,a,-c);
}
memset(dis,0x3f,sizeof(dis));
q.push(1),dis[1]=0,len[1]=1;
while(!q.empty())
{
u=q.front(),q.pop(),inq[u]=0;
for(i=head[u];i!=-1;i=next[i])
{
if(dis[to[i]]>dis[u]+val[i])
{
dis[to[i]]=dis[u]+val[i],len[to[i]]=len[u]+1;
if(len[to[i]]>n)
{
printf("-1");
return 0;
}
if(!inq[to[i]]) inq[to[i]]=1,q.push(to[i]);
}
}
}
if(dis[n]==0x3f3f3f3f) printf("-2");
else printf("%d",dis[n]);
return 0;
}

最新文章

  1. ACM/ICPC 之 DFS+SPFA-贪心+最短路(POJ2679)
  2. keil uvision3 添加 STC单片机库
  3. sdk更新代理设置
  4. 【2014】【辛星】【php】【秋季】【2】第一个php程序
  5. Probably at least one of the constraints in the following list is one you don&#39;t want.
  6. bitnami redmine 安装插件
  7. [ An Ac a Day ^_^ ] [kuangbin带你飞]专题五 并查集 POJ 2236 Wireless Network
  8. Filebeat issue 排查--single.go:140: ERR Connecting error publishing events (retrying): dial tcp ****:5044: i/o timeout
  9. LVS小型系统架构搭建笔记
  10. webapi Route 特性
  11. Android开发之欢迎界面标准
  12. go exec:exit status 64
  13. [LeetCode&amp;Python] Problem 682. Baseball Game
  14. Linux HugePages 配置与 Oracle 性能关系说明
  15. 20165218 实验二 Java面向对象程序设计
  16. 《DSP using MATLAB》示例Example 8.18
  17. 点滴积累【C#】---C#实现下载word
  18. 原生的ado.net(访问sql server数据库)
  19. rancher中级(二)(rancher中添加证书及操作虚拟主机)
  20. [Noip2016]换教室(期望+DP)

热门文章

  1. Zigbee事件
  2. 【转】Python——编码规范
  3. linux 修改时间
  4. 架构师-盛大许式伟VS金山张宴
  5. HTML里面的文本标签
  6. Atitit.biz业务系统&#160;面向框架&#160;&#160;面向模式---------数据映射imp
  7. java内存管理和gc回收机制
  8. Android Studio 使用笔记:[转] Mac下修改Android Studio 所用的JDK版本
  9. nginx+python+fastcgi环境配置(flup版本)
  10. Spring MVC Xml视图解析器