题目链接:

PKU:http://poj.org/problem?id=1861

ZJU:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=542

Description

Andrew is working as system administrator and is planning to establish a new network in his company. There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network,
each hub must be accessible by cables from any other hub (with possibly some intermediate hubs). 

Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one
because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections. 

You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied. 

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000). All hubs are numbered from 1 to N. The following M lines contain information about
possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot
be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding
cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4

Source

Northeastern Europe 2001, Northern Subregion

题意:

有n个顶点,m条边,每条边都是双向的,而且有一定的长度。要求使每一个顶点都连通,而且要使总长度最短,

输出最大边、边的总数和所选择的边。

PS:

貌似题目的案例有点问题,卡了好久!

应该输出的是:

1

3

1 3

2 3

2 4

代码例如以下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 15017;
int father[maxn];
struct edge
{
int x,y,v;
};
struct edge ed[maxn],ansa[maxn]; bool cmp(edge a,edge b)
{
return a.v<b.v;
} int find(int x)
{
if(x==father[x])
return x;
return father[x]=find(father[x]);
} void Krusal(int n,int m)
{
int i,fx,fy,cnt;
int ans=0;
for(i = 1; i <= n; i++)
father[i]=i;
sort(ed,ed+m,cmp);//对边的排序
cnt=0;
int max=-1;
for(i=0; i<m; i++)
{
fx=find(ed[i].x);
fy=find(ed[i].y);
if(fx!=fy)
{
ans+=ed[i].v;
father[fx]=fy;
ansa[cnt].x=ed[i].x;
ansa[cnt++].y=ed[i].y;
if(max<ed[i].v)
max=ed[i].v;
}
}
printf("%d\n%d\n",max,cnt);
for(i=0; i<cnt; i++)
printf("%d %d\n",ansa[i].x,ansa[i].y);
} int main()
{
int t;
int n, m;
int a, b, k; while(scanf("%d %d",&n,&m)!=EOF)
{
for(int i = 0; i < m; i++)
{
scanf("%d %d %d",&a,&b,&k);
ed[i].x=a,ed[i].y=b,ed[i].v=k;
}
Krusal(n,m);
}
return 0;
}

最新文章

  1. Xamarin技术文档------VS多平台开发
  2. ios webview自适应实际内容高度4种方法
  3. [转]搬瓦工换机房换ip之后不能连外网
  4. 理解assign,copy,retain变strong
  5. zabbix_agent安装(Centos+Ubuntu)
  6. 学习日记day9: PC端页面流程优化
  7. H264中的SPS、PPS提取与作用
  8. 目标识别:Bag-of-words表示图像
  9. 【USACO 2.3.2】奶牛家谱
  10. Android自定义工具类获取按钮并绑定事件(利用暴力反射和注解)
  11. Windows 2008 R2安装.NET Framework 4提示灾难性故障解决方法
  12. join on用法
  13. [bzoj省选十连测推广赛2]T2七彩树
  14. 电脑移动后WIFI连接失败解决方法
  15. Foundations of Game Engine Development Volume 1 Mathematics (Eric Lengyel 著)
  16. 编程一小时 code.org [六一关注]
  17. 团队第二次 # scrum meeting
  18. springboot与缓存(redis,或者caffeine,guava)
  19. web安全之攻击
  20. ci框架多语言切换

热门文章

  1. [C++]豆知识(1条)
  2. jquery怎样获得父级窗体的大小
  3. mysql增量备份(2/2)
  4. HTML5游戏探讨,怎样让微信游戏仅仅能执行在微信中
  5. Oracle转化成为百分比
  6. python重置变量 sys.defaultencoding
  7. SAXReader解析xml文件demo
  8. outline轮廓线在不同CSS样式下的表现
  9. URL中的#号
  10. 解决window10系统电脑插入耳机之后没有声音的问题