Censor

frog is now a editor to censor so-called sensitive words (敏感词).

She has a long text \(p\). Her job is relatively simple -- just to find the first occurence of sensitive word \(w\) and remove it.

frog repeats over and over again. Help her do the tedious work.

Input

The input consists of multiple tests. For each test:

The first line contains \(1\) string \(w\). The second line contains \(1\) string \(p\).

(\(1 \leq \textrm{length of}\ w, p \leq 5 \cdot 10^6\), \(w, p\) consists of only lowercase letter)

Output

For each test, write \(1\) string which denotes the censored text.

Sample Input

    abc
aaabcbc
b
bbb
abc
ab

Sample Output

    a

    ab

题目链接:SCU 4438

用哈希来做的话比KMP简单很多,每一次加入一个字符,看倒数Len个字符的哈希值是否和模式串相同,若相同则弹出Len个元素,否则再加入元素并更新哈希值

代码:

#include <stdio.h>
#include <bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
#define LC(x) (x<<1)
#define RC(x) ((x<<1)+1)
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
typedef pair<int, int> pii;
typedef unsigned long long ULL;
const double PI = acos(-1.0);
const int N = 5e6 + 7;
const ULL seed = 1e9 + 7;
char w[N], p[N], ans[N];
int lw, lp;
ULL prefix[N] = {1ull}, st[N]; ULL gethash(char s[], int len)
{
ULL hashval = 0ull;
for (int i = 0; i < len; ++i)
hashval = hashval * seed + s[i];
return hashval;
} int main(void)
{
int i;
for (i = 1; i < N; ++i)
prefix[i] = prefix[i - 1] * seed;
while (~scanf("%s%s", w, p))
{
lw = strlen(w);
lp = strlen(p);
ULL tar = gethash(w, lw);
int top = 0;
st[top] = 0;
for (i = 0; i < lp; ++i)
{
ans[top++] = p[i];
st[top] = st[top - 1] * seed + p[i];
if (top >= lw && st[top] - st[top - lw]*prefix[lw] == tar)
top -= lw;
}
ans[top] = '\0';
printf("%s\n", ans);
}
return 0;
}

最新文章

  1. iOS开发需要哪些图片?
  2. RCP:eclipse的DEBUG机制
  3. 【代码笔记】iOS-点评内容
  4. Code Simplicity–The Science of Software Development 书摘
  5. 史上最完整的Android开发工具集合
  6. Hbase 基本命令
  7. careercup-树与图 4.2
  8. scp 在不同机器上传文件
  9. Log4net 可直接使用的配置
  10. 【2017集美大学1412软工实践_助教博客】团队作业3——需求改进&amp;系统设计 成绩公示
  11. 基于Abp的WebApi容器
  12. java事件处理机制
  13. (三) Keras Mnist分类程序以及改用交叉熵对比
  14. ACM在线模板
  15. [原] RTTI 为什么type_info 有比较操作
  16. Javascript - ExtJs - 组件 - 分页
  17. 3.ELK 之elasticsearch CRUD
  18. switch语句(初学者)
  19. Asp.net core 学习笔记 ( DI 依赖注入 )
  20. 创建springboot的聚合工程(三)

热门文章

  1. 运维自动化之Cobbler系统安装详解
  2. java Html&amp;JavaScript面试题:用table显示n条记录,每3行换一次颜色,即1,2,3用红色字体,4,5,6用绿色字体,7,8,9用红颜色字体。
  3. SpringVC 拦截器+自定义注解 实现权限拦截
  4. Zabbix监控告警Lack of free swap space on Zabbix server解决办法
  5. vim粘贴取消自动缩进
  6. ZendFramework-2.4 源代码 - 关于MVC - View层 - 在模板内渲染子模板
  7. Table 分页处理
  8. ArcGis API for JavaScript学习——离线部署API
  9. HDU:2594-Simpsons’ Hidden Talents
  10. Git-GIt检出