题目链接:

pid=4930">http://acm.hdu.edu.cn/showproblem.php?

pid=4930

Fighting the Landlords

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 546 Accepted Submission(s): 188

Problem Description
Fighting the Landlords is a card game which has been a heat for years in China. The game goes with the 54 poker cards for 3 players, where the “Landlord” has 20 cards and the other two (the “Farmers”) have 17. The Landlord wins if
he/she has no cards left, and the farmer team wins if either of the Farmer have no cards left. The game uses the concept of hands, and some fundamental rules are used to compare the cards. For convenience, here we only consider the following categories of
cards:



1.Solo: a single card. The priority is: Y (i.e. colored Joker) > X (i.e. Black & White Joker) > 2 > A (Ace) > K (King) > Q (Queen) > J (Jack) > T (10) > 9 > 8 > 7 > 6 > 5 > 4 > 3. It’s the basic rank of cards.



2.Pair : two matching cards of equal rank (e.g. 3-3, 4-4, 2-2 etc.). Note that the two Jokers cannot form a Pair (it’s another category of cards). The comparison is based on the rank of Solo, where 2-2 is the highest, A-A comes second, and 3-3 is the lowest.



3.Trio: three cards of the same rank (e.g. 3-3-3, J-J-J etc.). The priority is similar to the two categories above: 2-2-2 > A-A-A > K-K-K > . . . > 3-3-3.



4.Trio-Solo: three cards of the same rank with a Solo as the kicker. Note that the Solo and the Trio should be different rank of cards (e.g. 3-3-3-A, 4-4-4-X etc.). Here, theKicker’s rank is irrelevant to the comparison, and the Trio’s rank
determines the priority. For example, 4-4-4-3 > 3-3-3-2.



5.Trio-Pair : three cards of the same rank with a Pair as the kicker (e.g. 3-3- 3-2-2, J-J-J-Q-Q etc.). The comparison is as the same as Trio-Solo, where the Trio is the only factor to be considered. For example,4-4-4-5-5 > 3-3-3-2-2. Note again, that two jokers
cannot form a Pair.



6.Four-Dual: four cards of the same rank with two cards as the kicker. Here,
it’s allowed for the two kickers to share the same rank.
The four same cards dominates the comparison: 5-5-5-5-3-4 > 4-4-4-4-2-2.



In the categories above, a player can only beat the prior hand using of the same category but not the others. For example, only a prior Solo can beat a Solo while a Pair cannot. But there’re exceptions:



7.Nuke: X-Y (JOKER-joker). It can beat everything in the game.



8.Bomb: 4 cards of the same rank. It can beat any other category except Nuke or another Bomb with a higher rank. The rank of Bombs follows the rank of individual cards: 2-2-2-2 is the highest and 3-3-3-3 is the lowest.



Given the cards of both yours and the next player’s, please judge whether you have a way to play a hand of cards that the next player cannot beat youin this round. If you no longer have cards after playing, we consider that he cannot beat you
either. You may see the sample for more details.
Input
The input contains several test cases. The number of test cases T (T<=20) occurs in the first line of input.



Each test case consists of two lines. Both of them contain a string indicating your cards and the next player’s, respectively. The length of each string doesn’t exceed 17, andeach single card will occur at most 4 times totally on two players’ hands
except that the two Jokers each occurs only once.
Output
For each test case, output Yes if you can reach your goal, otherwise output No.
Sample Input
4
33A
2
33A
22
33
22
5559T
9993
Sample Output
Yes
No
Yes
Yes
Author
BUPT
Source

题目意思:

两个人设为A和B,A和B在打斗地主,上面一行是A手里的牌,以下一行是B手里的牌,若A第一次出牌B压不住或者A一次就把牌出完了。那么输出Yes,否则若A牌没出完并且被B压住了那么输出No。

代码例如以下:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
#define M 26
char s1[M], s2[M];
int c1[M], c2[M];
int a1[M], a2[M];
int b1[M], b2[M];
int len1, len2;
int max(int a, int b)
{
return a > b ? a:b;
} void init()
{
memset(a1,0,sizeof(a1));
memset(b1,0,sizeof(b1));
memset(a2,0,sizeof(a1));
memset(b2,0,sizeof(b2));
memset(c1,0,sizeof(c1));
memset(c2,0,sizeof(c2));
}
int f(char c)
{
if(c >= '3' && c <= '9')
return c -'2';
if(c == 'T')
return 8;
if(c == 'J')
return 9;
if(c == 'Q')
return 10;
if(c == 'K')
return 11;
if(c == 'A')
return 12;
if(c == '2')
return 13;
if(c == 'X')
return 14;
if(c == 'Y')
return 15;
}
void Find(int *c, int flag)
{
int i;
int a[6], b[6];
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
for(i = 1; i <= 13; i++)
{
if(c[i])
{
b[1] = max(b[1],i);
if(c[i] == 1)//单张
{
a[1]++;
}
else if(c[i] == 2)//对子
{
a[2]++;
b[2] = max(b[2],i);
}
else if(c[i] == 3)//三个的
{
a[3]++;
b[3] = max(b[3],i);
}
else if(c[i] == 4)//炸弹
{
a[4]++;
b[4] = max(b[4],i);
}
}
}
if(c[14] && c[15])//双王
{
b[1] = 15;
a[5]++;
}
else if(c[15])//大王
{
b[1] = 15;
}
else if(c[14])//小王
{
b[1] = 14;
} for(i = 1; i <= 5; i++)
{
if(flag == 1)
{
a1[i] = a[i];
b1[i] = b[i];
}
else if(flag == 2)
{
a2[i] = a[i];
b2[i] = b[i];
}
}
}
void solve()
{
int i, j;
int flag1, flag2;
int n1=strlen(s1);
int n2=strlen(s2);
if((n1==1)||(n1==2&&a1[2])||(n1==3&&a1[3])||(n1==4&&(a1[4]||a1[3]))||(n1==5&&a1[2]&&a1[3])||(n1==6&&a1[2]&&a1[4]))
{
printf("Yes\n");//一次出完
}
else if(a1[5])
{
printf("Yes\n"); //A手里有王炸
}
else if(a2[5])
{
printf("No\n"); //B手里有王炸
}
else if(b1[4]>b2[4])
{
printf("Yes\n"); //A手里的炸弹比B手里的炸弹大
}
else if(b1[4]<b2[4]) //反之
{
printf("No\n");
}
else if(b1[1]>b2[1]) //出单,且单比B的大
{
printf("Yes\n");
}
else if(b1[2]>b2[2]) //出对,且对照B的大
{
printf("Yes\n");
}
else if(b1[3]&&(b1[3]>b2[3]||(b1[1]&&!b2[1])||(b1[2]&&!b2[2])))
{ //出3张时,能够带1张也能够带2张也能够不带。依次推断
printf("Yes\n");
}
else
{
printf("No\n");
}
}
int main()
{
int t;
int i, j;
scanf("%d",&t);
while(t--)
{
init();
scanf("%s",s1);
scanf("%s",s2);
len1 = strlen(s1);
len2 = strlen(s2);
for(i = 0; i < len1; i++)
{
c1[f(s1[i])]++;
}
for(i = 0; i < len2; i++)
{
c2[f(s2[i])]++;
}
Find(c1, 1);
Find(c2, 2);
solve();
}
return 0;
}

最新文章

  1. C语言之socket获取网页源码
  2. javascript高级程序设计---Element对象
  3. Mergely – 免费的在线文档对比和合并工具
  4. 使用服务器端控制AJAX页面缓存
  5. C#利用GDI+绘制旋转文字等效果
  6. js获取url的各项参数
  7. 软件测试学习日志————round 0 An impressed error in my past projects
  8. As Fast As Possible
  9. C# 使用Process调用外部程序中所遇到的参数问题
  10. Linux进程间通信-消息队列(mqueue)
  11. 简单实现Python调用有道API接口(最新的)
  12. MongoDB 中的【加减乘除】运算
  13. python程序—士兵出击
  14. nvm use 指定版本后无效 win7
  15. WPF datagrid 设置表头线与颜色、透明度
  16. Scrapy框架--代理和cookie
  17. java基础-day12
  18. 进程process与线程thread
  19. Drools 语法
  20. Codeforces Round #189 (Div. 2) D. Psychos in a Line 单调队列dp

热门文章

  1. FIRST SCRAPY PRJ
  2. IOS深入学习(21)之Key-value coding
  3. MFC/C++/C中字符类型CString, int, string, char*之间的转换
  4. 关于js拖拽功能,拖拽元素的position:fixed;left:0;right:0;样式引起左右拖动元素会出现落后鼠标移动距离的问题
  5. mysql的grant权限参数汇总
  6. Android AutoCompleteTextView控件实现类似百度搜索提示,限制输入数字长度
  7. Javascript 中的 apply与call详解
  8. 2017 CCPC 湘潭邀请赛
  9. spark完整的数据倾斜解决方案
  10. luogu P1146 硬币翻转