Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

分析:两个集合共有的元素个数 / 两个集合合并后的元素个数.

有一组超时,待改进:

#include<iostream>
#include<set>
#include<vector>
using namespace std;
int main()
{
int N;
int i,count,j,t;
cin>>N;
vector< set<int> > vec(N);
for(i=0; i<N; i++){
scanf("%d",&count);
for(j=0; j<count; j++){
scanf("%d",&t);
vec[i].insert(t);
}
}
int request,a,b;
scanf("%d",&request);
for(i=0; i<request; i++){
scanf("%d %d",&a,&b);
set<int> temp_set;
set<int>::iterator it;
for(it = vec[a-1].begin(); it != vec[a-1].end(); it++){
temp_set.insert( *it );
}
for(it = vec[b-1].begin(); it != vec[b-1].end(); it++){
temp_set.insert( *it );
} printf( "%.1f",(float)( vec[a-1].size()+vec[b-1].size()-temp_set.size())*100/(float)(temp_set.size()) );
cout<<"%"<<endl;
}
return 0;
}

最新文章

  1. Git bash下中文乱码问题
  2. Angularjs1培训
  3. phpmyadmin的root密码忘记了怎么办?
  4. 转:union和union all的区别
  5. jsti 和EL用法注意点
  6. java匿名类和匿名对象及this的其他用法
  7. Scalaz(4)- typeclass:标准类型-Equal,Order,Show,Enum
  8. C++开发的基于UDP协议的聊天工具
  9. aehyok.com的成长之路一——开篇
  10. Android Studio:libpng warning: iCCP: Not recognizing known sRGB profile that has been edited解决办法
  11. JavaScript的正则表达式使用
  12. TCP/UDP简易通信
  13. C# 经典入门12章-System.Collections.Generic命名空间
  14. wamp虚拟服务器
  15. 40. Combination Sum II(midum, backtrack, 重要)
  16. vue-resource post请求后台接口报400(跨域问题解决方法)
  17. C#基础加强(7)之ref与out
  18. vue-cli —— 项目打包及一些注意事项
  19. ARMV8 datasheet学习笔记3:AArch64应用级体系结构之Memory order
  20. ajax和iframe区别

热门文章

  1. linux 使用中括号进行条件判断
  2. bzoj 4069~4071 APIO2015
  3. Charles 3断点篡改数据
  4. 传统项目利用Hystrix实现热点接口的服务隔离
  5. Jenkins是什么?
  6. leetcode73
  7. 1 数据库开发--MySQL介绍
  8. Git---远程仓库之从远程仓库克隆03
  9. [Android开源项目] GitHub开源项目总结 (转)
  10. 并发之CAS无锁技术