A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 595    Accepted Submission(s): 308

Problem Description
Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year.

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

 
Input
There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

 
Output
For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.
 
Sample Input
10001
0
333
 
Sample Output
Case #1: YES
Case #2: YES
Case #3: NO
 
Author
UESTC
 
Source
 
 
 
解析:大数取模。给你一个数,问这个数是否能同时整除73和137。而73和137均为素数,也就是判断这个数能否整除10001。
 
 
 
#include <cstdio>

const int MAXN = 10000000+5;
char s[MAXN]; int main()
{
int cn = 0;
while(~scanf("%s", s)){
int mod = 0;
for(int i = 0; s[i] != '\0'; ++i){
mod = (mod*10+s[i]-'0')%10001;
}
if(mod == 0)
printf("Case #%d: YES\n", ++cn);
else
printf("Case #%d: NO\n", ++cn);
}
return 0;
}

  

最新文章

  1. 利用TortoiseSVN获取最新版本的OpenCV源码
  2. js获取当前坐标
  3. C Primer Plus_第10章_数组和指针_编程练习
  4. ecs CentOS 7 安装 mysql (mariadb)
  5. LoadRunner11录制APP脚本(2)
  6. Bootstrap Modals(模态框)
  7. 错误是无法将“XXX”转换为“System.CompenentModel.Design.Serialization.InstanceDescrip”问题的解决办法
  8. Oracle优化器介绍
  9. 022 UFT虚拟对象
  10. Geodatabase - 创建要素类.
  11. IntelliJ IDEA中创建并运行scala应用程序
  12. grep、egrep、fgrep的用法与特性详解
  13. Docker私有仓库--自签名方式
  14. [Swift]LeetCode621. 任务调度器 | Task Scheduler
  15. python flask 解决中文乱码
  16. 写一个ORM框架的第一步(Apache Commons DbUtils)
  17. js - 伪数组转化为数组的几种方法整理(更新中...)
  18. java.lang.IllegalStateException: Ambiguous mapping. Cannot map &#39;waterQuality
  19. 2008-03-18 22:58 oracle基础知识小结
  20. 分形在遥感和GIS中的应用

热门文章

  1. Java 泛型(Generics)
  2. java Hotspot 内存管理白皮书(中文翻译)
  3. POJ 2106 Boolean Expressions (布尔表达式求值)
  4. 1009-2的N次方
  5. Windows JDK环境变量的配置
  6. hdu 3863 No Gambling
  7. tomcat免重启随意更改java代码 提高开发效率
  8. React 性能调优原理
  9. phpcms V9首页 频道页 列表页 推荐位 简单获取文章浏览量和评论统计
  10. js中鼠标滚轮事件详解